dunst.nix 744 B

12345678910111213141516171819202122232425262728293031323334
  1. {colorscheme}:
  2. with colorscheme.colors; {
  3. global = {
  4. width = 300;
  5. height = 100;
  6. offset = "30x50";
  7. origin = "top-right";
  8. transparency = 10;
  9. background = "#${base00}";
  10. frame_color = "#${base06}"; # border
  11. font = "Iosevka Nerd Font 10";
  12. notification_limit = 5;
  13. layer = "overlay"; # bottom, top or overlay
  14. fullscreen = "pushback";
  15. browser = "xdg-open";
  16. corner_radius = 0;
  17. };
  18. urgency_low = {
  19. background = "#${base00}";
  20. foreground = "#${base05}";
  21. timeout = 3;
  22. };
  23. urgency_normal = {
  24. background = "#${base00}";
  25. foreground = "#${base06}";
  26. timeout = 5;
  27. };
  28. urgency_critical = {
  29. foreground = "#${base0D}";
  30. frame_color = "#${base08}";
  31. timeout = 8;
  32. };
  33. }