perl-template.SlackBuild 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159
  1. #!/bin/sh
  2. # Slackware build script for <appname>
  3. # Copyright <year> <you> <where you live>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # |-----------------------------------------------------------------| #
  23. # REMOVE THIS ENTIRE BLOCK OF TEXT #
  24. #
  25. # A license is required, and we strongly suggest you use the above
  26. # BSD/MIT style license. We DO NOT accept "Public Domain" scripts.
  27. # Public domain is not valid in some countries, and no license is
  28. # worse than a "bad" license in those countries.
  29. #
  30. # This template is not meant to be a 'cut and paste' script to
  31. # enable any random user to make a working package. While
  32. # we're certainly not discouraging use of this template, if
  33. # you haven't manually gone through each step of the process
  34. # without the build script (typically as a normal user, as this
  35. # will reveal problems that you won't see as root), then there's
  36. # a good chance that something important is missing from your
  37. # submission.
  38. # When using this template script, please remove as many of
  39. # these unnecessary comments as possible. Commented code is
  40. # a good thing, but if it's obvious, there's no need to comment it.
  41. #
  42. # AGAIN, REMOVE THE COMMENTS IF THEY ARE NOT NEEDED - DON'T JUST
  43. # DELETE THIS BLOCK OF TEXT WITHOUT BOTHERING TO READ WHAT'S IN IT.
  44. #
  45. # |-----------------------------------------------------------------| #
  46. PRGNAM=perl-appname # replace "appname" with name of program
  47. VERSION=${VERSION:-1.4.1} # replace with version of program
  48. BUILD=${BUILD:-1}
  49. TAG=${TAG:-_SBo} # the "_SBo" is required
  50. SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
  51. # Automatically determine the architecture we're building on:
  52. if [ -z "$ARCH" ]; then
  53. case "$( uname -m )" in
  54. i?86) ARCH=i586 ;;
  55. arm*) ARCH=arm ;;
  56. # Unless $ARCH is already set, use uname -m for all other archs:
  57. *) ARCH=$( uname -m ) ;;
  58. esac
  59. fi
  60. CWD=$(pwd)
  61. TMP=${TMP:-/tmp/SBo} # For consistency's sake, use this
  62. PKG=$TMP/package-$PRGNAM
  63. OUTPUT=${OUTPUT:-/tmp} # Drop the package in /tmp
  64. if [ "$ARCH" = "i586" ]; then
  65. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  66. LIBDIRSUFFIX=""
  67. elif [ "$ARCH" = "i686" ]; then
  68. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  69. LIBDIRSUFFIX=""
  70. elif [ "$ARCH" = "x86_64" ]; then
  71. SLKCFLAGS="-O2 -fPIC"
  72. LIBDIRSUFFIX="64"
  73. else
  74. SLKCFLAGS="-O2"
  75. LIBDIRSUFFIX=""
  76. fi
  77. set -e
  78. rm -rf $PKG
  79. mkdir -p $TMP $PKG $OUTPUT
  80. cd $TMP
  81. rm -rf $SRCNAM-$VERSION
  82. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  83. cd $SRCNAM-$VERSION
  84. chown -R root:root .
  85. find -L . \
  86. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  87. -o -perm 511 \) -exec chmod 755 {} \; -o \
  88. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  89. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  90. # Your application may need different flags; these are provided as examples
  91. # There seem to be two different methods for building perl apps:
  92. # Build method #1 (preferred)
  93. perl Makefile.PL \
  94. PREFIX=/usr \
  95. INSTALLDIRS=vendor \
  96. INSTALLVENDORMAN1DIR=/usr/man/man1 \
  97. INSTALLVENDORMAN3DIR=/usr/man/man3
  98. make
  99. make test
  100. make install DESTDIR=$PKG
  101. # Build method #2
  102. # requires perl-Module-Build or perl-Module-Build-Tiny
  103. perl Build.PL \
  104. --installdirs vendor \
  105. --config installvendorman1dir=/usr/man/man1 \
  106. --config installvendorman3dir=/usr/man/man3
  107. ./Build
  108. ./Build test
  109. ./Build install \
  110. --destdir $PKG
  111. # Strip binaries and libraries -
  112. # If this is not needed,remove it from the script.
  113. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  114. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  115. # Compress man pages
  116. find $PKG/usr/man -type f -exec gzip -9 {} \;
  117. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  118. # Remove perllocal.pod and other special files that don't need to be installed,
  119. # as they will overwrite what's already on the system.
  120. find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
  121. # Remove empty directories
  122. find $PKG -depth -type d -empty -delete || true
  123. # Copy program documentation into the package
  124. # The included documentation varies from one application to another, so be sure
  125. # to adjust your script as needed
  126. # Also, include the SlackBuild script in the documentation directory
  127. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  128. cp -a \
  129. <documentation> \
  130. $PKG/usr/doc/$PRGNAM-$VERSION
  131. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  132. # Copy the slack-desc into ./install
  133. mkdir -p $PKG/install
  134. cat $CWD/slack-desc > $PKG/install/slack-desc
  135. # Make the package; be sure to leave it in $OUTPUT
  136. cd $PKG
  137. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}