123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159 |
- #!/bin/sh
- # Slackware build script for <appname>
- # Copyright <year> <you> <where you live>
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- # |-----------------------------------------------------------------| #
- # REMOVE THIS ENTIRE BLOCK OF TEXT #
- #
- # A license is required, and we strongly suggest you use the above
- # BSD/MIT style license. We DO NOT accept "Public Domain" scripts.
- # Public domain is not valid in some countries, and no license is
- # worse than a "bad" license in those countries.
- #
- # This template is not meant to be a 'cut and paste' script to
- # enable any random user to make a working package. While
- # we're certainly not discouraging use of this template, if
- # you haven't manually gone through each step of the process
- # without the build script (typically as a normal user, as this
- # will reveal problems that you won't see as root), then there's
- # a good chance that something important is missing from your
- # submission.
- # When using this template script, please remove as many of
- # these unnecessary comments as possible. Commented code is
- # a good thing, but if it's obvious, there's no need to comment it.
- #
- # AGAIN, REMOVE THE COMMENTS IF THEY ARE NOT NEEDED - DON'T JUST
- # DELETE THIS BLOCK OF TEXT WITHOUT BOTHERING TO READ WHAT'S IN IT.
- #
- # |-----------------------------------------------------------------| #
- PRGNAM=perl-appname # replace "appname" with name of program
- VERSION=${VERSION:-1.4.1} # replace with version of program
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo} # the "_SBo" is required
- SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
- # Automatically determine the architecture we're building on:
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- CWD=$(pwd)
- TMP=${TMP:-/tmp/SBo} # For consistency's sake, use this
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp} # Drop the package in /tmp
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $SRCNAM-$VERSION
- tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
- cd $SRCNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Your application may need different flags; these are provided as examples
- # There seem to be two different methods for building perl apps:
- # Build method #1 (preferred)
- perl Makefile.PL \
- PREFIX=/usr \
- INSTALLDIRS=vendor \
- INSTALLVENDORMAN1DIR=/usr/man/man1 \
- INSTALLVENDORMAN3DIR=/usr/man/man3
- make
- make test
- make install DESTDIR=$PKG
- # Build method #2
- # requires perl-Module-Build or perl-Module-Build-Tiny
- perl Build.PL \
- --installdirs vendor \
- --config installvendorman1dir=/usr/man/man1 \
- --config installvendorman3dir=/usr/man/man3
- ./Build
- ./Build test
- ./Build install \
- --destdir $PKG
- # Strip binaries and libraries -
- # If this is not needed,remove it from the script.
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- # Compress man pages
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
- # Remove perllocal.pod and other special files that don't need to be installed,
- # as they will overwrite what's already on the system.
- find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
- # Remove empty directories
- find $PKG -depth -type d -empty -delete || true
- # Copy program documentation into the package
- # The included documentation varies from one application to another, so be sure
- # to adjust your script as needed
- # Also, include the SlackBuild script in the documentation directory
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a \
- <documentation> \
- $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- # Copy the slack-desc into ./install
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- # Make the package; be sure to leave it in $OUTPUT
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|