hardware-configuration.nix 355 B

123456789101112131415161718
  1. { modulesPath, ... }:
  2. {
  3. imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
  4. boot.loader.grub.device = "/dev/sda";
  5. boot.initrd.availableKernelModules = [
  6. "ata_piix"
  7. "uhci_hcd"
  8. "vmw_pvscsi"
  9. "xen_blkfront"
  10. ];
  11. boot.initrd.kernelModules = [ "nvme" ];
  12. fileSystems."/" = {
  13. device = "/dev/sda1";
  14. fsType = "ext4";
  15. };
  16. }