1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
- ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages datamash)
- #:use-module (guix packages)
- #:use-module (guix licenses)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages base))
- (define-public datamash
- (package
- (name "datamash")
- (version "1.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/datamash/datamash-"
- version ".tar.gz"))
- (sha256
- (base32
- "15jrv3ly0vgvwwi2qjmhi39n7wrklwifdk961wwfaxyc5jr6zm78"))))
- (native-inputs
- `(("which" ,which) ;for tests
- ("perl" ,perl))) ;for help2man
- (build-system gnu-build-system)
- (home-page "https://www.gnu.org/software/datamash/")
- (synopsis "Scriptable statistics and data calculation")
- (description
- "Perform basic numeric, textual and statistical operations on plain text
- files. Designed to work within standard pipelines without additional code.")
- (license gpl3+)))
|