datamash.scm 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
  3. ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages datamash)
  20. #:use-module (guix packages)
  21. #:use-module (guix licenses)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (gnu packages perl)
  25. #:use-module (gnu packages base))
  26. (define-public datamash
  27. (package
  28. (name "datamash")
  29. (version "1.2")
  30. (source
  31. (origin
  32. (method url-fetch)
  33. (uri (string-append "mirror://gnu/datamash/datamash-"
  34. version ".tar.gz"))
  35. (sha256
  36. (base32
  37. "15jrv3ly0vgvwwi2qjmhi39n7wrklwifdk961wwfaxyc5jr6zm78"))))
  38. (native-inputs
  39. `(("which" ,which) ;for tests
  40. ("perl" ,perl))) ;for help2man
  41. (build-system gnu-build-system)
  42. (home-page "https://www.gnu.org/software/datamash/")
  43. (synopsis "Scriptable statistics and data calculation")
  44. (description
  45. "Perform basic numeric, textual and statistical operations on plain text
  46. files. Designed to work within standard pipelines without additional code.")
  47. (license gpl3+)))