tmux-3.3a-r2.ebuild 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889
  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit autotools flag-o-matic
  5. DESCRIPTION="Terminal multiplexer"
  6. HOMEPAGE="https://tmux.github.io/"
  7. if [[ ${PV} == 9999 ]] ; then
  8. inherit git-r3
  9. SRC_URI="https://raw.githubusercontent.com/przepompownia/tmux-bash-completion/678a27616b70c649c6701cae9cd8c92b58cc051b/completions/tmux -> tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b"
  10. EGIT_REPO_URI="https://github.com/tmux/tmux.git"
  11. else
  12. GH_COMMIT="381c00a74ea1eb136a97c86da9a7713190b10a62"
  13. SRC_URI="https://github.com/tmux/tmux/archive/${GH_COMMIT}.tar.gz -> ${P/_/-}-${GH_COMMIT}.tar.gz"
  14. if [[ ${PV} != *_rc* ]] ; then
  15. KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
  16. fi
  17. S="${WORKDIR}/${PN}-${GH_COMMIT}"
  18. fi
  19. LICENSE="ISC"
  20. SLOT="0"
  21. IUSE="debug selinux systemd utempter vim-syntax"
  22. DEPEND="
  23. dev-libs/libevent:=
  24. sys-libs/ncurses:=
  25. systemd? ( sys-apps/systemd:= )
  26. utempter? ( sys-libs/libutempter )
  27. kernel_Darwin? ( dev-libs/libutf8proc:= )
  28. "
  29. BDEPEND="
  30. virtual/pkgconfig
  31. app-alternatives/yacc
  32. "
  33. RDEPEND="
  34. ${DEPEND}
  35. selinux? ( sec-policy/selinux-screen )
  36. vim-syntax? ( app-vim/vim-tmux )
  37. "
  38. RESTRICT="mirror"
  39. DOCS=( CHANGES README )
  40. PATCHES=(
  41. "${FILESDIR}"/${PN}-2.4-flags.patch
  42. # "${FILESDIR}"/${P}-clang.patch
  43. # "${FILESDIR}"/${PN}-CVE-2022-40716.patch
  44. )
  45. src_prepare() {
  46. default
  47. eautoreconf
  48. }
  49. src_configure() {
  50. # bug 438558
  51. # 1.7 segfaults when entering copy mode if compiled with -Os
  52. replace-flags -Os -O2
  53. local myeconfargs=(
  54. --sysconfdir="${EPREFIX}"/etc
  55. $(use_enable debug)
  56. $(use_enable systemd)
  57. $(use_enable utempter)
  58. # For now, we only expose this for macOS, because
  59. # upstream strongly encourage it. I'm not sure it's
  60. # needed on Linux right now.
  61. $(use_enable kernel_Darwin utf8proc)
  62. )
  63. econf "${myeconfargs[@]}"
  64. }
  65. src_install() {
  66. default
  67. einstalldocs
  68. dodoc example_tmux.conf
  69. docompress -x /usr/share/doc/${PF}/example_tmux.conf
  70. }