1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889 |
- # Copyright 1999-2023 Gentoo Authors
- # Distributed under the terms of the GNU General Public License v2
- EAPI=8
- inherit autotools flag-o-matic
- DESCRIPTION="Terminal multiplexer"
- HOMEPAGE="https://tmux.github.io/"
- if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- SRC_URI="https://raw.githubusercontent.com/przepompownia/tmux-bash-completion/678a27616b70c649c6701cae9cd8c92b58cc051b/completions/tmux -> tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b"
- EGIT_REPO_URI="https://github.com/tmux/tmux.git"
- else
- GH_COMMIT="381c00a74ea1eb136a97c86da9a7713190b10a62"
- SRC_URI="https://github.com/tmux/tmux/archive/${GH_COMMIT}.tar.gz -> ${P/_/-}-${GH_COMMIT}.tar.gz"
- if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
- fi
- S="${WORKDIR}/${PN}-${GH_COMMIT}"
- fi
- LICENSE="ISC"
- SLOT="0"
- IUSE="debug selinux systemd utempter vim-syntax"
- DEPEND="
- dev-libs/libevent:=
- sys-libs/ncurses:=
- systemd? ( sys-apps/systemd:= )
- utempter? ( sys-libs/libutempter )
- kernel_Darwin? ( dev-libs/libutf8proc:= )
- "
- BDEPEND="
- virtual/pkgconfig
- app-alternatives/yacc
- "
- RDEPEND="
- ${DEPEND}
- selinux? ( sec-policy/selinux-screen )
- vim-syntax? ( app-vim/vim-tmux )
- "
- RESTRICT="mirror"
- DOCS=( CHANGES README )
- PATCHES=(
- "${FILESDIR}"/${PN}-2.4-flags.patch
- # "${FILESDIR}"/${P}-clang.patch
- # "${FILESDIR}"/${PN}-CVE-2022-40716.patch
- )
- src_prepare() {
- default
- eautoreconf
- }
- src_configure() {
- # bug 438558
- # 1.7 segfaults when entering copy mode if compiled with -Os
- replace-flags -Os -O2
- local myeconfargs=(
- --sysconfdir="${EPREFIX}"/etc
- $(use_enable debug)
- $(use_enable systemd)
- $(use_enable utempter)
- # For now, we only expose this for macOS, because
- # upstream strongly encourage it. I'm not sure it's
- # needed on Linux right now.
- $(use_enable kernel_Darwin utf8proc)
- )
- econf "${myeconfargs[@]}"
- }
- src_install() {
- default
- einstalldocs
- dodoc example_tmux.conf
- docompress -x /usr/share/doc/${PF}/example_tmux.conf
- }
|