12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455 |
- #!/usr/bin/make -f
- # Made with the aid of debmake, by Christoph Lameter,
- # based on the sample debian/rules file for GNU hello by Ian Jackson.
- package=kawa
- build:
- $(checkdir)
- ./configure --prefix=/usr
- make CFLAGS="-O2 -g -Wall"
- touch build
- clean:
- $(checkdir)
- -rm -f build
- -make distclean
- -rm -f `find . -name "*~"`
- -rm -rf debian/tmp debian/files* core debian/substvars
- binary-indep: checkroot build
- $(checkdir)
- # There are no architecture-independent files to be uploaded
- # generated by this package. If there were any they would be
- # made here.
- binary-arch: checkroot build
- $(checkdir)
- -rm -rf debian/tmp
- install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
- make install prefix=`pwd`/debian/tmp/usr
- cd doc; make kawa.html kawa.1
- # Must have debmake installed for this to work. Otherwise please copy
- # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
- debstd ChangeLog README TODO doc/*.html
- dpkg-gencontrol
- chown -R root.root debian/tmp
- chmod -R go=rX debian/tmp
- dpkg --build debian/tmp ..
- define checkdir
- test -f debian/rules
- endef
- # Below here is fairly generic really
- binary: binary-indep binary-arch
- checkroot:
- $(checkdir)
- test root = "`whoami`"
- .PHONY: binary binary-arch binary-indep clean checkroot
|