rules 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. #!/usr/bin/make -f
  2. # Made with the aid of debmake, by Christoph Lameter,
  3. # based on the sample debian/rules file for GNU hello by Ian Jackson.
  4. package=kawa
  5. build:
  6. $(checkdir)
  7. ./configure --prefix=/usr
  8. make CFLAGS="-O2 -g -Wall"
  9. touch build
  10. clean:
  11. $(checkdir)
  12. -rm -f build
  13. -make distclean
  14. -rm -f `find . -name "*~"`
  15. -rm -rf debian/tmp debian/files* core debian/substvars
  16. binary-indep: checkroot build
  17. $(checkdir)
  18. # There are no architecture-independent files to be uploaded
  19. # generated by this package. If there were any they would be
  20. # made here.
  21. binary-arch: checkroot build
  22. $(checkdir)
  23. -rm -rf debian/tmp
  24. install -d debian/tmp
  25. cd debian/tmp && install -d `cat ../dirs`
  26. make install prefix=`pwd`/debian/tmp/usr
  27. cd doc; make kawa.html kawa.1
  28. # Must have debmake installed for this to work. Otherwise please copy
  29. # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
  30. debstd ChangeLog README TODO doc/*.html
  31. dpkg-gencontrol
  32. chown -R root.root debian/tmp
  33. chmod -R go=rX debian/tmp
  34. dpkg --build debian/tmp ..
  35. define checkdir
  36. test -f debian/rules
  37. endef
  38. # Below here is fairly generic really
  39. binary: binary-indep binary-arch
  40. checkroot:
  41. $(checkdir)
  42. test root = "`whoami`"
  43. .PHONY: binary binary-arch binary-indep clean checkroot