123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224 |
- % Created 2021-12-25 Sat 18:11
- % Intended LaTeX compiler: pdflatex
- \documentclass[11pt]{article}
- \usepackage[utf8]{inputenc}
- \usepackage[T1]{fontenc}
- \usepackage{graphicx}
- \usepackage{grffile}
- \usepackage{longtable}
- \usepackage{wrapfig}
- \usepackage{rotating}
- \usepackage[normalem]{ulem}
- \usepackage{amsmath}
- \usepackage{textcomp}
- \usepackage{amssymb}
- \usepackage{capt-of}
- \usepackage{hyperref}
- \usepackage{tabularx}
- \usepackage{minted}
- \usepackage[top=70pt,bottom=70pt,left=50pt,right=50pt]{geometry}
- \usepackage{color}
- \definecolor{blue}{rgb}{0,0.5,1}
- \hypersetup{colorlinks=true, linkcolor=blue, urlcolor=blue, citecolor=blue}
- \usepackage{placeins}
- \author{Adam Salwowski}
- \date{\today}
- \title{Sprawozdanie z Administracji Systemów Komputerowych nr. 11}
- \hypersetup{
- pdfauthor={Adam Salwowski},
- pdftitle={Sprawozdanie z Administracji Systemów Komputerowych nr. 11},
- pdfkeywords={},
- pdfsubject={},
- pdfcreator={Emacs 27.1 (Org mode 9.3)},
- pdflang={English}}
- \begin{document}
- \maketitle
- \tableofcontents
- \newpage
- \section{Wstęp}
- \label{sec:orgef0acde}
- Zadania wykonałem na maszynie wirtualnej z systemem operacyjnym \texttt{Windows Embedded 8.1 Industry Pro Build 9600}. Wersja używanego oprogramowania: \texttt{Cisco Packet Tracer 8.0}. Do połączenia niektórych obrazów użyłem narzędzi z pakietu \texttt{imagemagick}.
- \section{Zadanie 1}
- \label{sec:org25764b1}
- \subsection{Zbudowany układ}
- \label{sec:orgc107e17}
- \begin{figure}[htbp]
- \centering
- \includegraphics[width=.9\linewidth]{./images/zad1_1.png}
- \caption{Zbudowany układ}
- \end{figure}
- \FloatBarrier
- Aby móc połączyć \emph{R1} z \emph{R0} kablem \emph{Serial DTE} jak na pożyższym zrzucie ekran należy dodać moduł z wejsciami serial o nazwie \emph{HWIC-2T}. Przed dodaniem, należy wyłączyć router przyciskiem po prawej stronie urządzenia.
- \begin{figure}[htbp]
- \centering
- \includegraphics[width=.9\linewidth]{./images/zad1_2.png}
- \caption{Router z dodanym modułem}
- \end{figure}
- \FloatBarrier
- \subsection{Wprowadzone komendy}
- \label{sec:org6045e9c}
- \begin{figure}[htbp]
- \centering
- \includegraphics[width=.9\linewidth]{./images/zad1_cli.png}
- \caption{CLI z wprowadzonymi komendami}
- \end{figure}
- \subsubsection{Do R1}
- \label{sec:org153d845}
- \begin{minted}[frame=lines,linenos=true,breaklines=true,breakanywhere=true]{text}
- enable
- configure terminal
- hostname R1
- interface fastethernet 0/0
- ip address 10.0.0.1 255.0.0.0
- no shutdown
- exit
- interface serial 0/1/0
- ip address 20.0.0.2 255.0.0.0
- no shutdown
- exit
- ip route 30.0.0.0 255.0.0.0 20.0.0.1
- ip nat inside source static 10.0.0.2 50.0.0.1
- interface fastEthernet 0/0
- ip nat inside
- exit
- interface serial 0/1/0
- ip nat outside
- exit
- \end{minted}
- \subsubsection{Do R0}
- \label{sec:org9dc5205}
- \begin{minted}[frame=lines,linenos=true,breaklines=true,breakanywhere=true]{text}
- enable
- configure terminal
- hostname R0
- interface fastEthernet 0/0
- ip address 30.0.0.1 255.0.0.0
- no shutdown
- exit
- interface serial 0/1/0
- ip address 20.0.0.1 255.0.0.0
- clock rate 64000
- bandwidth 64
- no shutdown
- exit
- ip route 50.0.0.0 255.0.0.0 20.0.0.2
- \end{minted}
- \subsection{Skonfigurowane interfejsy}
- \label{sec:orgc92e640}
- \begin{figure}[htbp]
- \centering
- \includegraphics[width=.9\linewidth]{./images/zad1_conf_pc.png}
- \caption{PC's oraz Server}
- \end{figure}
- \begin{figure}[htbp]
- \centering
- \includegraphics[width=.9\linewidth]{./images/zad1_conf_r.png}
- \caption{Routery}
- \end{figure}
- \FloatBarrier
- .\newpage
- \subsection{Ping}
- \label{sec:org00380d4}
- \begin{figure}[htbp]
- \centering
- \includegraphics[width=.9\linewidth]{./images/zad1_ping.png}
- \caption{Sygnał ICMP}
- \end{figure}
- \FloatBarrier
- Operacja przebiegła pomyślnie.
- \section{Zadanie 2}
- \label{sec:org852be59}
- \subsection{Zbudowany układ}
- \label{sec:org9c69f75}
- \begin{figure}[htbp]
- \centering
- \includegraphics[width=.9\linewidth]{./images/zad2_1.png}
- \caption{Zbudowany układ}
- \end{figure}
- \FloatBarrier
- \subsection{Wprowadzone komendy}
- \label{sec:org9f1fb53}
- \begin{figure}[htbp]
- \centering
- \includegraphics[width=.9\linewidth]{./images/zad2_cli.png}
- \caption{CLI routerów}
- \end{figure}
- \FloatBarrier
- \subsubsection{Do R1}
- \label{sec:orga0d49f1}
- \begin{minted}[frame=lines,linenos=true,breaklines=true,breakanywhere=true]{text}
- enable
- configure terminal
- hostname R1
- interface fastEthernet 0/0
- ip address 192.168.0.1 255.255.0.0
- no shutdown
- exit
- interface serial 0/1/0
- ip address 30.0.0.1 255.0.0.0
- clock rate 64000
- bandwidth 64
- no shutdown
- exit
- ip route 0.0.0.0 0.0.0.0 serial 0/1/0
- access-list 1 permit 192.168.0.0 0.0.0.255
- ip nat pool test 50.0.0.1 50.0.0.5 netmask 255.0.0.0
- ip nat inside source list 1 pool test
- interface fastEthernet 0/0
- ip nat inside
- exit
- interface serial 0/1/0
- ip nat outside
- exit
- \end{minted}
- \subsubsection{Do R2}
- \label{sec:org6fccca6}
- \begin{minted}[frame=lines,linenos=true,breaklines=true,breakanywhere=true]{text}
- enable
- configure terminal
- interface fastEthernet 0/0
- ip address 20.0.0.1 255.0.0.0
- no shutdown
- exit
- interface serial 0/1/0
- ip address 30.0.0.2 255.0.0.0
- no shutdown
- exit
- ip route 0.0.0.0 0.0.0.0 serial 0/1/0
- hostname R2
- \end{minted}
- \subsection{Skonfigurowane interfejsy}
- \label{sec:org1b03892}
- \begin{figure}[htbp]
- \centering
- \includegraphics[width=1\textwidth]{./images/zad2_conf_pc.png}
- \caption{PC's oraz Server}
- \end{figure}
- \begin{figure}[htbp]
- \centering
- \includegraphics[width=1\textwidth]{./images/zad2_conf_r.png}
- \caption{Routery}
- \end{figure}
- \FloatBarrier
- \subsection{Testowanie NAT}
- \label{sec:orgec83e95}
- Uruchamiam na R1 debugowanie NAT.
- \begin{figure}[htbp]
- \centering
- \includegraphics[height=0.5\textwidth]{./images/zad2_debug.png}
- \caption{Debug}
- \end{figure}
- \FloatBarrier
- \begin{figure}[htbp]
- \centering
- \includegraphics[height=0.5\textwidth]{./images/zad2_ping.png}
- \caption{Sygnał ICMP}
- \end{figure}
- \FloatBarrier
- Operacja echo request adresu 20.0.0.2 przebiegła pomyślnie z hosta o adresie 192.168.0.2 (PC0).
- \end{document}
|