\newpage
Zadania wykonałem na maszynie wirtualnej z systemem operacyjnym Windows Embedded 8.1 Industry Pro Build 9600
. Wersja używanego oprogramowania: Cisco Packet Tracer 8.0
. Do połączenia niektórych obrazów użyłem narzędzi z pakietu imagemagick
.
#+CAPTION: Zbudowany układ
./images/zad1_1.png
\FloatBarrier
Aby móc połączyć R1 z R0 kablem Serial DTE jak na pożyższym zrzucie ekran należy dodać moduł z wejsciami serial o nazwie HWIC-2T. Przed dodaniem, należy wyłączyć router przyciskiem po prawej stronie urządzenia.
#+CAPTION: Router z dodanym modułem
./images/zad1_2.png
\FloatBarrier
#+CAPTION: CLI z wprowadzonymi komendami
./images/zad1_cli.png
# \FloatBarrier
#+begin_src text
enable
configure terminal
hostname R1
interface fastethernet 0/0
ip address 10.0.0.1 255.0.0.0
no shutdown
exit
interface serial 0/1/0
ip address 20.0.0.2 255.0.0.0
no shutdown
exit
ip route 30.0.0.0 255.0.0.0 20.0.0.1
ip nat inside source static 10.0.0.2 50.0.0.1
interface fastEthernet 0/0
ip nat inside
exit
interface serial 0/1/0
ip nat outside
exit
#+end_src
#+begin_src text
enable
configure terminal
hostname R0
interface fastEthernet 0/0
ip address 30.0.0.1 255.0.0.0
no shutdown
exit
interface serial 0/1/0
ip address 20.0.0.1 255.0.0.0
clock rate 64000
bandwidth 64
no shutdown
exit
ip route 50.0.0.0 255.0.0.0 20.0.0.2
#+end_src
#+CAPTION: PC's oraz Server ./images/zad1_conf_pc.png #+CAPTION: Routery ./images/zad1_conf_r.png \FloatBarrier .\newpage #+CAPTION: Sygnał ICMP ./images/zad1_ping.png \FloatBarrier Operacja przebiegła pomyślnie. #+CAPTION: Zbudowany układ ./images/zad2_1.png \FloatBarrier #+CAPTION: CLI routerów ./images/zad2_cli.png \FloatBarrier #+begin_src text enable configure terminal hostname R1 interface fastEthernet 0/0 ip address 192.168.0.1 255.255.0.0 no shutdown exit interface serial 0/1/0 ip address 30.0.0.1 255.0.0.0 clock rate 64000 bandwidth 64 no shutdown exit ip route 0.0.0.0 0.0.0.0 serial 0/1/0 access-list 1 permit 192.168.0.0 0.0.0.255 ip nat pool test 50.0.0.1 50.0.0.5 netmask 255.0.0.0 ip nat inside source list 1 pool test interface fastEthernet 0/0 ip nat inside exit interface serial 0/1/0 ip nat outside exit #+end_src #+begin_src text enable configure terminal interface fastEthernet 0/0 ip address 20.0.0.1 255.0.0.0 no shutdown exit interface serial 0/1/0 ip address 30.0.0.2 255.0.0.0 no shutdown exit ip route 0.0.0.0 0.0.0.0 serial 0/1/0 hostname R2 #+end_src
#+CAPTION: PC's oraz Server #+ATTR_LATEX: :width 1\textwidth ./images/zad2_conf_pc.png #+CAPTION: Routery #+ATTR_LATEX: :width 1\textwidth ./images/zad2_conf_r.png \FloatBarrier Uruchamiam na R1 debugowanie NAT. #+CAPTION: Debug #+ATTR_LATEX: :height 0.5\textwidth ./images/zad2_debug.png \FloatBarrier #+CAPTION: Sygnał ICMP #+ATTR_LATEX: :height 0.5\textwidth ./images/zad2_ping.png \FloatBarrier Operacja echo request adresu 20.0.0.2 przebiegła pomyślnie z hosta o adresie 192.168.0.2 (PC0).