flake.nix 565 B

12345678910111213141516171819202122232425
  1. {
  2. description = "Control machine via voice";
  3. inputs = {
  4. vosk.url = "git+file:///home/oleg/.local/share/chezmoi?dir=src/nix/vosk";
  5. };
  6. outputs = { self, nixpkgs, vosk }:
  7. let
  8. system = "x86_64-linux";
  9. in {
  10. packages.${system} = rec {
  11. python3-vosk = nixpkgs.legacyPackages.${system}.python3.withPackages (python-packages:
  12. with python-packages; [
  13. aiohttp
  14. numpy
  15. pyaudio
  16. vosk.vosk
  17. websocket-client
  18. ]);
  19. default = python3-vosk;
  20. };
  21. };
  22. }