APKBUILD 854 B

123456789101112131415161718192021222324252627282930
  1. # Contributor: sick <sick@rape.lol>
  2. # Maintainer sick <sick@rape.lol>
  3. pkgname=toxcore
  4. pkgver=0.1.10
  5. pkgrel=0
  6. pkgdesc="Encrypted peer-to-peer instant messenger protocol library"
  7. url="https://tox.chat"
  8. arch="all"
  9. license="GPL-3"
  10. depends="libsodium"
  11. makedepends="$depends-dev opus-dev libvpx-dev autoconf automake libtool"
  12. subpackages="$pkgname-dev "
  13. source="c-$pkgname-$pkgver.tar.gz::https://github.com/TokTok/c-$pkgname/archive/v$pkgver.tar.gz"
  14. builddir="$srcdir/c-$pkgname-$pkgver"
  15. build() {
  16. cd "$builddir"
  17. ./autogen.sh
  18. ./configure --prefix=/usr --enable-daemon || return 1
  19. make || return 1
  20. }
  21. package() {
  22. cd "$builddir"
  23. make DESTDIR=$pkgdir install || return 1
  24. }
  25. sha512sums="2274346f941711579139c0dfb29cb916b04e6c3319ab6ebf99e4980d020b02e9fed6ae5edfebda98be58296bbe21ea02f441dc900ad54cd8873db0e6f02b8158 c-toxcore-0.1.10.tar.gz"