nginx-config.nix 609 B

123456789101112131415161718192021222324
  1. { config, pkgs, lib, ... }:
  2. {
  3. services.nginx = {
  4. enable = true;
  5. recommendedGzipSettings = true;
  6. recommendedOptimisation = true;
  7. recommendedProxySettings = true;
  8. recommendedTlsSettings = true;
  9. virtualHosts."gitea.local" = {
  10. enableACME = false;
  11. forceSSL = false;
  12. locations."/".proxyPass = "http://localhost:3001/";
  13. };
  14. virtualHosts."keycloak.local" = {
  15. enableACME = false;
  16. forceSSL = false;
  17. locations."/".proxyPass = "http://localhost:4080/";
  18. };
  19. # necessary to upload larger git repos via http
  20. clientMaxBodySize = "200m";
  21. };
  22. }