keycloak-config.nix 605 B

1234567891011121314151617181920212223242526
  1. { config, pkgs, lib, ... }:
  2. {
  3. services.keycloak = {
  4. enable = false;
  5. settings = {
  6. hostname = "keycloak.local";
  7. hostname-strict-backchannel = true;
  8. http-host = "127.0.0.1";
  9. http-port = 4080;
  10. #https-port = 4443;
  11. };
  12. initialAdminPassword = "tegMEHle6Wcm0Rr";
  13. #sslCertificate = "/run/keys/ssl_cert";
  14. #sslCertificateKey = "/run/keys/ssl_key";
  15. database = {
  16. type = "postgresql";
  17. username = "keycloak";
  18. host = "localhost";
  19. port = 5432;
  20. name = "keycloak";
  21. passwordFile = "/run/keys/keycloak-db-passfile";
  22. };
  23. };
  24. }