hardware-configuration.nix 1.2 KB

123456789101112131415161718192021222324252627282930313233
  1. # Do not modify this file! It was generated by ‘nixos-generate-config’
  2. # and may be overwritten by future invocations. Please make changes
  3. # to /etc/nixos/configuration.nix instead.
  4. { config, lib, pkgs, modulesPath, ... }:
  5. {
  6. imports =
  7. [ (modulesPath + "/profiles/qemu-guest.nix")
  8. ];
  9. boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "virtio_pci" "sr_mod" "virtio_blk" ];
  10. boot.initrd.kernelModules = [ ];
  11. boot.kernelModules = [ "kvm-intel" ];
  12. boot.extraModulePackages = [ ];
  13. fileSystems."/" =
  14. { device = "/dev/disk/by-uuid/bc020c18-09a8-492f-8750-7a6981134ff7";
  15. fsType = "ext4";
  16. };
  17. swapDevices = [ ];
  18. # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
  19. # (the default) this is the recommended approach. When using systemd-networkd it's
  20. # still possible to use this option, but it's recommended to use it in conjunction
  21. # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
  22. networking.useDHCP = lib.mkDefault true;
  23. # networking.interfaces.enp1s0.useDHCP = lib.mkDefault true;
  24. nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
  25. hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
  26. }