123456789101112131415161718192021222324 |
- { config, pkgs, lib, ... }:
- {
- services.nginx = {
- enable = true;
- recommendedGzipSettings = true;
- recommendedOptimisation = true;
- recommendedProxySettings = true;
- recommendedTlsSettings = true;
- virtualHosts."gitea.local" = {
- enableACME = false;
- forceSSL = false;
- locations."/".proxyPass = "http://localhost:3001/";
- };
- virtualHosts."keycloak.local" = {
- enableACME = false;
- forceSSL = false;
- locations."/".proxyPass = "http://localhost:4080/";
- };
- # necessary to upload larger git repos via http
- clientMaxBodySize = "200m";
- };
- }
|