123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160 |
- # Edit this configuration file to define what should be installed on
- # your system. Help is available in the configuration.nix(5) man page
- # and in the NixOS manual (accessible by running ‘nixos-help’).
- { config, pkgs, ... }:
- let
- #personalunixhacks = fetchGit "https://notabug.org/strlst/personalunixhacks";
- personalunixhacks = /root/dotfiles/misc/personalunixhacks;
- in
- {
- imports =
- [ # Include the results of the hardware scan.
- ./hardware-configuration.nix
- /root/nix/postgresql-config.nix
- /root/nix/nginx-config.nix
- /root/nix/acme-config.nix
- /root/nix/gitea-config.nix
- /root/nix/keycloak-config.nix
- ];
- # Use the GRUB 2 boot loader.
- boot.loader.grub.enable = true;
- boot.loader.grub.version = 2;
- # boot.loader.grub.efiSupport = false;
- # boot.loader.grub.efiInstallAsRemovable = true;
- # boot.loader.efi.efiSysMountPoint = "/boot/efi";
- # Define on which hard drive you want to install Grub.
- boot.loader.grub.device = "/dev/vda"; # or "nodev" for efi only
- # networking.hostName = "nixos"; # Define your hostname.
- # Pick only one of the below networking options.
- # networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
- # networking.networkmanager.enable = true; # Easiest to use and most distros use this by default.
- # Set your time zone.
- time.timeZone = "Europe/Zurich";
- # Configure network proxy if necessary
- # networking.proxy.default = "http://user:password@proxy:port/";
- # networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
- # Select internationalisation properties.
- # i18n.defaultLocale = "en_US.UTF-8";
- # console = {
- # font = "Lat2-Terminus16";
- # keyMap = "us";
- # useXkbConfig = true; # use xkbOptions in tty.
- # };
- # Enable the X11 windowing system.
- services.xserver.enable = true;
- services.xserver.windowManager.dwm.enable = true;
- services.xserver.displayManager.lightdm.enable = true;
- # autoLogin doesn't work for some reason
- services.xserver.displayManager.defaultSession = "none+dwm";
- services.xserver.displayManager.autoLogin.enable = true;
- services.xserver.displayManager.autoLogin.user = "root";
- services.xserver.resolutions = [{x = 1920; y = 1080;}];
- nixpkgs.overlays = [
- (final: prev: {
- dwm = prev.dwm.overrideAttrs (old: { src = "${personalunixhacks}/dwm-6.1"; });
- st = prev.st.overrideAttrs (old: { src = "${personalunixhacks}/st-0.8.2"; });
- dmenu = prev.dmenu.overrideAttrs (old: { src = "${personalunixhacks}/dmenu-4.7"; });
- slstatus = prev.slstatus.overrideAttrs (old: { src = "${personalunixhacks}/slstatus"; });
- })
- ];
- fonts.fonts = with pkgs; [
- mplus-outline-fonts.githubRelease
- ubuntu_font_family
- #terminus # unmaintained :(
- #ubuntu
- ];
- # Configure keymap in X11
- services.xserver.layout = "us";
- # services.xserver.xkbOptions = {
- # "eurosign:e";
- # "caps:escape" # map caps to escape.
- # };
- # Enable CUPS to print documents.
- # services.printing.enable = true;
- # Enable sound.
- # sound.enable = true;
- # hardware.pulseaudio.enable = true;
- # Enable touchpad support (enabled default in most desktopManager).
- # services.xserver.libinput.enable = true;
- # Define a user account. Don't forget to set a password with ‘passwd’.
- # users.users.alice = {
- # isNormalUser = true;
- # extraGroups = [ "wheel" ]; # Enable ‘sudo’ for the user.
- # packages = with pkgs; [
- # firefox
- # thunderbird
- # ];
- # };
- # List packages installed in system profile. To search, run:
- # $ nix search wget
- environment.systemPackages = with pkgs; [
- neovim
- wget
- git
- st
- dmenu
- slstatus
- firefox
- system-sendmail
- ];
- # Some programs need SUID wrappers, can be configured further or are
- # started in user sessions.
- # programs.mtr.enable = true;
- programs.gnupg.agent = {
- enable = true;
- enableSSHSupport = true;
- };
- # List services that you want to enable:
- # Enable the OpenSSH daemon.
- services.openssh.enable = true;
- # Open ports in the firewall.
- # networking.firewall.allowedTCPPorts = [ ... ];
- # networking.firewall.allowedUDPPorts = [ ... ];
- # Or disable the firewall altogether.
- # networking.firewall.enable = false;
- networking.extraHosts = ''
- 127.0.0.1 gitea.local
- 127.0.0.1 keycloak.local
- '';
- # Copy the NixOS configuration file and link it from the resulting system
- # (/run/current-system/configuration.nix). This is useful in case you
- # accidentally delete configuration.nix.
- # system.copySystemConfiguration = true;
- # This value determines the NixOS release from which the default
- # settings for stateful data, like file locations and database versions
- # on your system were taken. It‘s perfectly fine and recommended to leave
- # this value at the release version of the first install of this system.
- # Before changing this value read the documentation for this option
- # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
- system.stateVersion = "22.11"; # Did you read the comment?
- # Enable libvirt spice server guest tools
- services.spice-vdagentd.enable = true;
- services.qemuGuest.enable = true;
- }
|