rules 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. #!/usr/bin/make -f
  2. # Uncomment this to turn on verbose mode.
  3. #export DH_VERBOSE=1
  4. PREFIX := debian/openmsx-catapult/usr
  5. PY_SUP_PREFIX := $(PREFIX)/share/python-support/openmsx-catapult
  6. build: build-stamp
  7. build-stamp:
  8. dh_testdir
  9. $(MAKE) build
  10. docbook-to-man debian/openmsx-catapult.sgml > debian/openmsx-catapult.1
  11. touch build-stamp
  12. clean:
  13. dh_testdir
  14. dh_testroot
  15. rm -f build-stamp
  16. -$(MAKE) clean
  17. -rm -rf debian/openmsx-catapult
  18. -rm -f debian/openmsx-catapult.1
  19. dh_clean
  20. install: build
  21. dh_testdir
  22. dh_testroot
  23. dh_clean -k
  24. dh_installdirs
  25. install *.py $(PY_SUP_PREFIX)
  26. chmod a-x $(PY_SUP_PREFIX)/*.py
  27. chmod a+x $(PY_SUP_PREFIX)/catapult.py
  28. # Build architecture-independent files here.
  29. binary-indep: build install
  30. dh_testdir
  31. dh_testroot
  32. dh_pysupport
  33. dh_python
  34. dh_installchangelogs ChangeLog
  35. dh_installdocs
  36. dh_installmenu
  37. dh_installman debian/openmsx-catapult.1
  38. dh_link usr/share/python-support/openmsx-catapult/catapult.py usr/bin/openmsx-catapult
  39. dh_strip
  40. dh_compress
  41. dh_fixperms
  42. dh_installdeb
  43. dh_shlibdeps
  44. dh_gencontrol
  45. dh_md5sums
  46. dh_builddeb
  47. # Build architecture-dependent files here.
  48. binary-arch: build install
  49. binary: binary-indep binary-arch
  50. .PHONY: build clean binary-indep binary-arch binary install