123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566 |
- #!/usr/bin/make -f
- # uncomment this to turn on verbose mode.
- #export DH_VERBOSE=1
- TARGET=$(shell grep -m1 TARGET Makefile | sed "s/ //g" | cut -d "=" -f 2)
- CFLAGS = -Wall -g
- ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
- else
- CFLAGS += -O2
- endif
- configure: configure-stamp
- configure-stamp:
- dh_testdir
- ./config.sh --platform linux
- touch configure-stamp
- build: build-stamp
- build-stamp: configure-stamp
- dh_testdir
- $(MAKE) STRIP=/bin/true
- touch $@
- clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
- [ ! -f Makefile ] || $(MAKE) distclean
- dh_clean
- install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- $(MAKE) DESTDIR=$(CURDIR)/debian/megazeux install
- # Build architecture-independent files here.
- binary-indep: build install
- # We have nothing to do by default.
- # Build architecture-dependent files here.
- binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installman
- dh_link megazeux.1 usr/share/man/man1/$(TARGET).1
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
- binary: binary-indep binary-arch
- .PHONY: build clean binary-indep binary-arch binary install configure
|