pybitmessage.spec 10.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233
  1. Name: pybitmessage
  2. Version: 0.3.5
  3. Release: 1%{?dist}
  4. Summary: Send encrypted messages
  5. License: MIT
  6. URL: https://github.com/Bitmessage/PyBitmessage
  7. Packager: Bob Mottram (4096 bits) <bob@robotics.uk.to>
  8. Source0: http://yourdomainname.com/src/%{name}_%{version}.orig.tar.gz
  9. Group: Office/Email
  10. Requires: python, PyQt4, openssl-compat-bitcoin-libs, gst123
  11. %description
  12. Bitmessage is a P2P communications protocol used to send encrypted messages
  13. to another person or to many subscribers. It is decentralized and
  14. trustless, meaning that you need-not inherently trust any entities like
  15. root certificate authorities. It uses strong authentication which means
  16. that the sender of a message cannot be spoofed, and it aims to hide
  17. "non-content" data, like the sender and receiver of messages, from passive
  18. eavesdroppers like those running warrantless wiretapping programs.
  19. %prep
  20. %setup -q
  21. %build
  22. %configure
  23. make %{?_smp_mflags}
  24. %install
  25. rm -rf %{buildroot}
  26. mkdir -p %{buildroot}
  27. mkdir -p %{buildroot}/etc
  28. mkdir -p %{buildroot}/etc/%{name}
  29. mkdir -p %{buildroot}/usr
  30. mkdir -p %{buildroot}/usr/bin
  31. mkdir -p %{buildroot}/usr/share
  32. mkdir -p %{buildroot}/usr/share/man
  33. mkdir -p %{buildroot}/usr/share/man/man1
  34. mkdir -p %{buildroot}/usr/share/%{name}
  35. mkdir -p %{buildroot}/usr/share/applications
  36. mkdir -p %{buildroot}/usr/share/icons
  37. mkdir -p %{buildroot}/usr/share/icons/hicolor
  38. mkdir -p %{buildroot}/usr/share/icons/hicolor/24x24
  39. mkdir -p %{buildroot}/usr/share/icons/hicolor/24x24/apps
  40. mkdir -p %{buildroot}/usr/share/pixmaps
  41. mkdir -p %{buildroot}/usr/share/icons/hicolor/scalable
  42. mkdir -p %{buildroot}/usr/share/icons/hicolor/scalable/apps
  43. # Make install but to the RPM BUILDROOT directory
  44. make install -B DESTDIR=%{buildroot} PREFIX=/usr
  45. %files
  46. %doc README.md LICENSE
  47. %defattr(-,root,root,-)
  48. %dir /usr/share/%{name}
  49. %dir /usr/share/applications
  50. %dir /usr/share/icons/hicolor
  51. %dir /usr/share/icons/hicolor/24x24
  52. %dir /usr/share/icons/hicolor/24x24/apps
  53. %dir /usr/share/pixmaps
  54. %dir /usr/share/icons/hicolor/scalable
  55. %dir /usr/share/icons/hicolor/scalable/apps
  56. /usr/share/%{name}/*
  57. %{_bindir}/*
  58. %{_mandir}/man1/*
  59. %attr(644,root,root) /usr/share/applications/%{name}.desktop
  60. %attr(644,root,root) /usr/share/icons/hicolor/24x24/apps/%{name}.png
  61. %changelog
  62. * Mon Jul 29 2013 Bob Mottram (4096 bits) <bob@robotics.uk.to> - 0.3.5-1
  63. - Inbox message retrieval API functions now also returns read status
  64. - Added right-click option to mark a message as unread
  65. - Prompt user to connect at first startup
  66. - Install into /usr/local by default
  67. - Add a missing rm -f to the uninstall task.
  68. - Use system text color for enabled addresses instead of black
  69. - Added support for Chans
  70. - Start storing msgid in sent table
  71. - Optionally play sounds on connection/disconnection or when messages arrive
  72. - Adding configuration option to listen for connections when using SOCKS
  73. - Added packaging for multiple distros (Arch, Puppy, Slack, etc.)
  74. - Added Russian translation
  75. - Added search support in the UI
  76. - Added 'make uninstall'
  77. - To improve OSX support, use PKCS5_PBKDF2_HMAC_SHA1 if PKCS5_PBKDF2_HMAC is unavailable
  78. - Added better warnings for OSX users who are using old versions of Python
  79. - Repaired debian packaging
  80. - Altered Makefile to avoid needing to chase changes
  81. - Added logger module
  82. - Added bgWorker class for background tasks
  83. - Added use of gevent module
  84. - On not-Windows: Fix insecure keyfile permissions
  85. - Fix 100% CPU usage issue
  86. * Sun Jun 30 2013 Bob Mottram (4096 bits) <bob@robotics.uk.to> - 0.3.4-1
  87. - Switched addr, msg, broadcast, and getpubkey message types
  88. to 8 byte time. Last remaining type is pubkey.
  89. - Added tooltips to show the full subject of messages
  90. - Added Maximum Acceptable Difficulty fields in the settings
  91. - Send out pubkey immediately after generating deterministic
  92. addresses rather than waiting for a request
  93. * Sat Jun 29 2013 Bob Mottram (4096 bits) <bob@robotics.uk.to> - 0.3.3-1
  94. - Remove inbox item from GUI when using API command trashMessage
  95. - Add missing trailing semicolons to pybitmessage.desktop
  96. - Ensure $(DESTDIR)/usr/bin exists
  97. - Update Makefile to correct sandbox violations when built
  98. via Portage (Gentoo)
  99. - Fix message authentication bug
  100. * Fri Jun 28 2013 Bob Mottram (4096 bits) <bob@robotics.uk.to> - 0.3.211-1
  101. - Removed multi-core proof of work
  102. as the multiprocessing module does not work well with
  103. pyinstaller's --onefile option.
  104. * Mon Jun 03 2013 Bob Mottram (4096 bits) <bob@robotics.uk.to> - 0.3.2-1
  105. - Bugfix: Remove remaining references to the old myapp.trayIcon
  106. - Refactored message status-related code. API function getStatus
  107. now returns one of these strings: notfound, msgqueued,
  108. broadcastqueued, broadcastsent, doingpubkeypow, awaitingpubkey,
  109. doingmsgpow, msgsent, or ackreceived
  110. - Moved proof of work to low-priority multi-threaded child
  111. processes
  112. - Added menu option to delete all trashed messages
  113. - Added inv flooding attack mitigation
  114. - On Linux, when selecting Show Bitmessage, do not maximize
  115. automatically
  116. - Store tray icons in bitmessage_icons_rc.py
  117. * Sat May 25 2013 Jonathan Warren (4096 bits) <jonathan@bitmessage.org> - 0.3.1-1
  118. - Added new API commands: getDeterministicAddress,
  119. addSubscription, deleteSubscription
  120. - TCP Connection timeout for non-fully-established connections
  121. now 20 seconds
  122. - Don't update the time we last communicated with a node unless
  123. the connection is fully established. This will allow us to
  124. forget about active but non-Bitmessage nodes which have made
  125. it into our knownNodes file.
  126. - Prevent incoming connection flooding from crashing
  127. singleListener thread. Client will now only accept one
  128. connection per remote node IP
  129. - Bugfix: Worker thread crashed when doing a POW to send out
  130. a v2 pubkey (bug introduced in 0.3.0)
  131. - Wrap all sock.shutdown functions in error handlers
  132. - Put all 'commit' commands within SQLLocks
  133. - Bugfix: If address book label is blank, Bitmessage wouldn't
  134. show message (bug introduced in 0.3.0)
  135. - Messaging menu item selects the oldest unread message
  136. - Standardize on 'Quit' rather than 'Exit'
  137. - [OSX] Try to seek homebrew installation of OpenSSL
  138. - Prevent multiple instances of the application from running
  139. - Show 'Connected' or 'Connection Lost' indicators
  140. - Use only 9 half-open connections on Windows but 32 for
  141. everyone else
  142. - Added appIndicator (a more functional tray icon) and Ubuntu
  143. Messaging Menu integration
  144. - Changed Debian install directory and run script name based
  145. on Github issue #135
  146. * Tue May 6 2013 Bob Mottram (4096 bits) <bob@sluggish.dyndns.org> - 0.3.0-1
  147. - Added new API function: getStatus
  148. - Added error-handling around all sock.sendall() functions
  149. in the receiveData thread so that if there is a problem
  150. sending data, the threads will close gracefully
  151. - Abandoned and removed the connectionsCount data structure;
  152. use the connectedHostsList instead because it has proved to be
  153. more accurate than trying to maintain the connectionsCount
  154. - Added daemon mode. All UI code moved into a module and many
  155. shared objects moved into shared.py
  156. - Truncate display of very long messages to avoid freezing the UI
  157. - Added encrypted broadcasts for v3 addresses or v2 addresses
  158. after 2013-05-28 10:00 UTC
  159. - No longer self.sock.close() from within receiveDataThreads,
  160. let the sendDataThreads do it
  161. - Swapped out the v2 announcements subscription address for a v3
  162. announcements subscription address
  163. - Vacuum the messages.dat file once a month: will greatly reduce the file size
  164. - Added a settings table in message.dat
  165. - Implemented v3 addresses:
  166. pubkey messages must now include two var_ints: nonce_trials_per_byte
  167. and extra_bytes, and also be signed. When sending a message to a v3
  168. address, the sender must use these values in calculating its POW or
  169. else the message will not be accepted by the receiver.
  170. - Display a privacy warning when selecting 'Send Broadcast from this address'
  171. - Added gitignore file
  172. - Added code in preparation for a switch from 32-bit time to 64-bit time.
  173. Nodes will now advertise themselves as using protocol version 2.
  174. - Don't necessarily delete entries from the inventory after 2.5 days;
  175. leave pubkeys there for 28 days so that we don't process the same ones
  176. many times throughout a month. This was causing the 'pubkeys processed'
  177. indicator on the 'Network Status' tab to not accurately reflect the
  178. number of truly new addresses on the network.
  179. - Use 32 threads for outgoing connections in order to connect quickly
  180. - Fix typo when calling os.environ in the sys.platform=='darwin' case
  181. - Allow the cancelling of a message which is in the process of being
  182. sent by trashing it then restarting Bitmessage
  183. - Bug fix: can't delete address from address book
  184. * Tue Apr 9 2013 Bob Mottram (4096 bits) <bob@sluggish.dyndns.org> - 0.2.8-1
  185. - Fixed Ubuntu & OS X issue:
  186. Bitmessage wouldn't receive any objects from peers after restart.
  187. - Inventory flush to disk when exiting program now vastly faster.
  188. - Fixed address generation bug (kept Bitmessage from restarting).
  189. - Improve deserialization of messages
  190. before processing (a 'best practice').
  191. - Change to help Macs find OpenSSL the way Unix systems find it.
  192. - Do not share or accept IPs which are in the private IP ranges.
  193. - Added time-fuzzing
  194. to the embedded time in pubkey and getpubkey messages.
  195. - Added a knownNodes lock
  196. to prevent an exception from sometimes occurring when saving
  197. the data-structure to disk.
  198. - Show unread messages in bold
  199. and do not display new messages automatically.
  200. - Support selecting multiple items
  201. in the inbox, sent box, and address book.
  202. - Use delete key to trash Inbox or Sent messages.
  203. - Display richtext(HTML) messages
  204. from senders in address book or subscriptions (although not
  205. pseudo-mailing-lists; use new right-click option).
  206. - Trim spaces
  207. from the beginning and end of addresses when adding to
  208. address book, subscriptions, and blacklist.
  209. - Improved the display of the time for foreign language users.
  210. * Tue Apr 1 2013 Bob Mottram (4096 bits) <bob@sluggish.dyndns.org> - 0.2.7-1
  211. - Added debian packaging
  212. - Script to generate debian packages
  213. - SVG icon for Gnome shell, etc
  214. - Source moved int src directory for debian standards compatibility
  215. - Trailing carriage return on COPYING LICENSE and README.md