changelog 8.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242
  1. pybitmessage (0.3.5-1) raring; urgency=low
  2. * Inbox message retrieval API functions now also returns read status
  3. * Added right-click option to mark a message as unread
  4. * Prompt user to connect at first startup
  5. * Install into /usr/local by default
  6. * Add a missing rm -f to the uninstall task.
  7. * Use system text color for enabled addresses instead of black
  8. * Added support for Chans
  9. * Start storing msgid in sent table
  10. * Optionally play sounds on connection/disconnection or when messages arrive
  11. * Adding configuration option to listen for connections when using SOCKS
  12. * Added packaging for multiple distros (Arch, Puppy, Slack, etc.)
  13. * Added Russian translation
  14. * Added search support in the UI
  15. * Added 'make uninstall'
  16. * To improve OSX support, use PKCS5_PBKDF2_HMAC_SHA1 if PKCS5_PBKDF2_HMAC is unavailable
  17. * Added better warnings for OSX users who are using old versions of Python
  18. * Repaired debian packaging
  19. * Altered Makefile to avoid needing to chase changes
  20. * Added logger module
  21. * Added bgWorker class for background tasks
  22. * Added use of gevent module
  23. * On not-Windows: Fix insecure keyfile permissions
  24. * Fix 100% CPU usage issue
  25. -- Bob Mottram (4096 bits) <bob@robotics.uk.to> Mon, 29 July 2013 22:11:00 +0100
  26. pybitmessage (0.3.4-1) raring; urgency=low
  27. * Switched addr, msg, broadcast, and getpubkey message types
  28. to 8 byte time. Last remaining type is pubkey.
  29. * Added tooltips to show the full subject of messages
  30. * Added Maximum Acceptable Difficulty fields in the settings
  31. * Send out pubkey immediately after generating deterministic
  32. addresses rather than waiting for a request
  33. -- Bob Mottram (4096 bits) <bob@robotics.uk.to> Sun, 30 June 2013 11:23:00 +0100
  34. pybitmessage (0.3.3-1) raring; urgency=low
  35. * Remove inbox item from GUI when using API command trashMessage
  36. * Add missing trailing semicolons to pybitmessage.desktop
  37. * Ensure $(DESTDIR)/usr/bin exists
  38. * Update Makefile to correct sandbox violations when built
  39. via Portage (Gentoo)
  40. * Fix message authentication bug
  41. -- Bob Mottram (4096 bits) <bob@robotics.uk.to> Sat, 29 June 2013 11:23:00 +0100
  42. pybitmessage (0.3.211-1) raring; urgency=low
  43. * Removed multi-core proof of work
  44. as the multiprocessing module does not work well with
  45. pyinstaller's --onefile option.
  46. -- Bob Mottram (4096 bits) <bob@robotics.uk.to> Fri, 28 June 2013 11:23:00 +0100
  47. pybitmessage (0.3.2-1) raring; urgency=low
  48. * Bugfix: Remove remaining references to the old myapp.trayIcon
  49. * Refactored message status-related code. API function getStatus
  50. now returns one of these strings: notfound, msgqueued,
  51. broadcastqueued, broadcastsent, doingpubkeypow, awaitingpubkey,
  52. doingmsgpow, msgsent, or ackreceived
  53. * Moved proof of work to low-priority multi-threaded child
  54. processes
  55. * Added menu option to delete all trashed messages
  56. * Added inv flooding attack mitigation
  57. * On Linux, when selecting Show Bitmessage, do not maximize
  58. automatically
  59. * Store tray icons in bitmessage_icons_rc.py
  60. -- Bob Mottram (4096 bits) <bob@robotics.uk.to> Mon, 03 June 2013 20:17:00 +0100
  61. pybitmessage (0.3.1-1) raring; urgency=low
  62. * Added new API commands: getDeterministicAddress,
  63. addSubscription, deleteSubscription
  64. * TCP Connection timeout for non-fully-established connections
  65. now 20 seconds
  66. * Don't update the time we last communicated with a node unless
  67. the connection is fully established. This will allow us to
  68. forget about active but non-Bitmessage nodes which have made
  69. it into our knownNodes file.
  70. * Prevent incoming connection flooding from crashing
  71. singleListener thread. Client will now only accept one
  72. connection per remote node IP
  73. * Bugfix: Worker thread crashed when doing a POW to send out
  74. a v2 pubkey (bug introduced in 0.3.0)
  75. * Wrap all sock.shutdown functions in error handlers
  76. * Put all 'commit' commands within SQLLocks
  77. * Bugfix: If address book label is blank, Bitmessage wouldn't
  78. show message (bug introduced in 0.3.0)
  79. * Messaging menu item selects the oldest unread message
  80. * Standardize on 'Quit' rather than 'Exit'
  81. * [OSX] Try to seek homebrew installation of OpenSSL
  82. * Prevent multiple instances of the application from running
  83. * Show 'Connected' or 'Connection Lost' indicators
  84. * Use only 9 half-open connections on Windows but 32 for
  85. everyone else
  86. * Added appIndicator (a more functional tray icon) and Ubuntu
  87. Messaging Menu integration
  88. * Changed Debian install directory and run script name based
  89. on Github issue #135
  90. -- Jonathan Warren (4096 bits) <jonathan@bitmessage.org> Sat, 25 May 2013 12:06:00 +0100
  91. pybitmessage (0.3.0-1) raring; urgency=low
  92. * Added new API function: getStatus
  93. * Added error-handling around all sock.sendall() functions
  94. in the receiveData thread so that if there is a problem
  95. sending data, the threads will close gracefully
  96. * Abandoned and removed the connectionsCount data structure;
  97. use the connectedHostsList instead because it has proved to be
  98. more accurate than trying to maintain the connectionsCount
  99. * Added daemon mode. All UI code moved into a module and many
  100. shared objects moved into shared.py
  101. * Truncate display of very long messages to avoid freezing the UI
  102. * Added encrypted broadcasts for v3 addresses or v2 addresses
  103. after 2013-05-28 10:00 UTC
  104. * No longer self.sock.close() from within receiveDataThreads,
  105. let the sendDataThreads do it
  106. * Swapped out the v2 announcements subscription address for a v3
  107. announcements subscription address
  108. * Vacuum the messages.dat file once a month: will greatly reduce the file size
  109. * Added a settings table in message.dat
  110. * Implemented v3 addresses:
  111. pubkey messages must now include two var_ints: nonce_trials_per_byte
  112. and extra_bytes, and also be signed. When sending a message to a v3
  113. address, the sender must use these values in calculating its POW or
  114. else the message will not be accepted by the receiver.
  115. * Display a privacy warning when selecting 'Send Broadcast from this address'
  116. * Added gitignore file
  117. * Added code in preparation for a switch from 32-bit time to 64-bit time.
  118. Nodes will now advertise themselves as using protocol version 2.
  119. * Don't necessarily delete entries from the inventory after 2.5 days;
  120. leave pubkeys there for 28 days so that we don't process the same ones
  121. many times throughout a month. This was causing the 'pubkeys processed'
  122. indicator on the 'Network Status' tab to not accurately reflect the
  123. number of truly new addresses on the network.
  124. * Use 32 threads for outgoing connections in order to connect quickly
  125. * Fix typo when calling os.environ in the sys.platform=='darwin' case
  126. * Allow the cancelling of a message which is in the process of being
  127. sent by trashing it then restarting Bitmessage
  128. * Bug fix: can't delete address from address book
  129. -- Bob Mottram (4096 bits) <bob@sluggish.dyndns.org> Tue, 6 May 2013 12:06:00 +0100
  130. pybitmessage (0.2.8-1) unstable; urgency=low
  131. * Fixed Ubuntu & OS X issue:
  132. Bitmessage wouldn't receive any objects from peers after restart.
  133. * Inventory flush to disk when exiting program now vastly faster.
  134. * Fixed address generation bug (kept Bitmessage from restarting).
  135. * Improve deserialization of messages
  136. before processing (a 'best practice').
  137. * Change to help Macs find OpenSSL the way Unix systems find it.
  138. * Do not share or accept IPs which are in the private IP ranges.
  139. * Added time-fuzzing
  140. to the embedded time in pubkey and getpubkey messages.
  141. * Added a knownNodes lock
  142. to prevent an exception from sometimes occurring when saving
  143. the data-structure to disk.
  144. * Show unread messages in bold
  145. and do not display new messages automatically.
  146. * Support selecting multiple items
  147. in the inbox, sent box, and address book.
  148. * Use delete key to trash Inbox or Sent messages.
  149. * Display richtext(HTML) messages
  150. from senders in address book or subscriptions (although not
  151. pseudo-mailing-lists; use new right-click option).
  152. * Trim spaces
  153. from the beginning and end of addresses when adding to
  154. address book, subscriptions, and blacklist.
  155. * Improved the display of the time for foreign language users.
  156. -- Bob Mottram (4096 bits) <bob@sluggish.dyndns.org> Tue, 9 Apr 2013 17:44:00 +0100
  157. pybitmessage (0.2.7-1) unstable; urgency=low
  158. * Added debian packaging
  159. * Script to generate debian packages
  160. * SVG icon for Gnome shell, etc
  161. * Source moved int src directory for debian standards compatibility
  162. * Trailing carriage return on COPYING LICENSE and README.md
  163. -- Bob Mottram (4096 bits) <bob@sluggish.dyndns.org> Tue, 1 Apr 2013 17:12:14 +0100