dolphin-emu.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. #
  2. # Spec file for package Dolphin Emulator
  3. #
  4. # Copyright © 2014 Markus S. <kamikazow@web.de>
  5. #
  6. # This program is free software: you can redistribute it and/or modify
  7. # it under the terms of the GNU General Public License as published by
  8. # the Free Software Foundation, either version 2 of the License, or
  9. # (at your option) any later version.
  10. #
  11. # This program is distributed in the hope that it will be useful,
  12. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  13. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. # GNU General Public License for more details.
  15. #
  16. # You should have received a copy of the GNU General Public License
  17. # along with this program. If not, see <http://www.gnu.org/licenses/>.
  18. Name: dolphin-emu
  19. Summary: Dolphin Emulator
  20. Version: 5.0
  21. Release: 0%{?dist}
  22. Group: System/Emulators/Other
  23. License: GPL-2.0
  24. URL: https://dolphin-emu.org/
  25. BuildArch: x86_64 armv7l aarch64
  26. # For this spec file to work, the Dolphin Emulator sources must be located
  27. # in a directory named dolphin-emu-5.0 (with "5.0" being the version
  28. # number defined above).
  29. # If the sources are compressed in another format than .tar.xz, change the
  30. # file extension accordingly.
  31. Source0: %{name}-%{version}.tar.xz
  32. # Package names verified with, CentOS, Fedora and openSUSE.
  33. # Should the packages in your distro be named differently,
  34. # see http://en.opensuse.org/openSUSE:Build_Service_cross_distribution_howto
  35. #
  36. # All other distros should work as well as Dolphin bundles
  37. # its dependencies for static linking.
  38. BuildRequires: desktop-file-utils
  39. BuildRequires: cmake >= 2.8
  40. BuildRequires: gcc-c++
  41. BuildRequires: gtk2-devel
  42. BuildRequires: pkgconfig(alsa)
  43. BuildRequires: pkgconfig(ao)
  44. BuildRequires: pkgconfig(bluez)
  45. BuildRequires: pkgconfig(libpulse)
  46. BuildRequires: pkgconfig(xrandr)
  47. BuildRequires: pkgconfig(zlib)
  48. %if 0%{?fedora}
  49. BuildRequires: libusb-devel
  50. BuildRequires: lzo-devel
  51. # Disable miniupnpc in OBS for F20
  52. BuildRequires: miniupnpc-devel
  53. BuildRequires: openal-soft-devel
  54. #polarssl is now mbedtls:
  55. BuildRequires: mbedtls-devel
  56. BuildRequires: SDL2-devel
  57. BuildRequires: SFML-devel
  58. BuildRequires: soundtouch-devel
  59. %endif
  60. %if 0%{?suse_version}
  61. BuildRequires: libminiupnpc-devel
  62. BuildRequires: libSDL2-devel
  63. BuildRequires: lzo-devel
  64. BuildRequires: openal-devel
  65. BuildRequires: sfml-devel
  66. BuildRequires: soundtouch-devel
  67. BuildRequires: update-desktop-files
  68. %endif
  69. # Use bundled wxGTK 3 except under the following distros:
  70. %if 0%{?fedora_version} > 20
  71. BuildRequires: wxGTK3-devel
  72. %endif
  73. %description
  74. Dolphin is an emulator for two Nintendo video game consoles, GameCube and the Wii.
  75. It allows PC gamers to enjoy games for these two consoles in full HD with several
  76. enhancements such as compatibility with all PC controllers, turbo speed,
  77. networked multiplayer, and more.
  78. Most games run perfectly or with minor bugs.
  79. # ------------------------------------------------------
  80. %package lang
  81. Summary: Translations for Dolphin Emulator
  82. BuildArch: noarch
  83. %description lang
  84. Translations into various languages for Dolphin Emulator
  85. %files lang
  86. %{_datadir}/locale
  87. # ------------------------------------------------------
  88. %package nogui
  89. Summary: Dolphin Emulator without a graphical user interface
  90. %description nogui
  91. Dolphin Emulator without a graphical user interface
  92. %files nogui
  93. %{_bindir}/%{name}-nogui
  94. %{_mandir}/man6/%{name}-nogui.*
  95. # ------------------------------------------------------
  96. %prep
  97. %setup -q
  98. %build
  99. export CCFLAGS='%{optflags}'
  100. cmake . -DCMAKE_INSTALL_PREFIX=/usr
  101. make %{?_smp_mflags}
  102. %install
  103. export CCFLAGS='%{optflags}'
  104. make %{?_smp_mflags} install DESTDIR="%{?buildroot}"
  105. %if 0%{?suse_version}
  106. # Replace desktop file category 'Game;Emulator;' with 'System;Emulator;'
  107. # under openSUSE or else build fails.
  108. %suse_update_desktop_file -c %name Dolphin 'GameCube and Wii emulator' %{name} %{name} 'System;Emulator;'
  109. %endif
  110. %files
  111. %defattr(-,root,root,-)
  112. %doc license.txt Readme.md
  113. %{_bindir}/%{name}
  114. %{_datadir}/%{name}
  115. %{_datadir}/icons/hicolor/48x48/apps/%{name}.*
  116. %{_datadir}/icons/hicolor/scalable/apps/%{name}.*
  117. %{_datadir}/applications/%{name}.desktop
  118. %{_mandir}/man6/%{name}.*
  119. %clean
  120. rm -rf %{buildroot}
  121. %changelog