default.nix 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. {
  2. lib,
  3. sway-unwrapped,
  4. stdenv,
  5. systemd,
  6. wlroots_0_16,
  7. # Used by the NixOS module:
  8. isNixOS ? false,
  9. enableXWayland ? true,
  10. systemdSupport ? lib.meta.availableOn stdenv.hostPlatform systemd,
  11. trayEnabled ? systemdSupport,
  12. sources,
  13. }:
  14. (sway-unwrapped.override {
  15. inherit
  16. isNixOS
  17. enableXWayland
  18. systemdSupport
  19. trayEnabled
  20. ;
  21. wlroots = wlroots_0_16;
  22. }).overrideAttrs
  23. (_oldAttrs: {
  24. inherit (sources.swayfx) pname version src;
  25. meta = with lib; {
  26. description = "Sway, but with eye candy!";
  27. homepage = "https://github.com/WillPower3309/swayfx";
  28. license = licenses.mit;
  29. maintainers = with maintainers; [ ludovicopiero ];
  30. platforms = platforms.linux;
  31. mainProgram = "sway";
  32. longDescription = ''
  33. Fork of Sway, an incredible and one of the most well established Wayland
  34. compositors, and a drop-in replacement for the i3 window manager for X11.
  35. SwayFX adds extra options and effects to the original Sway, such as rounded corners,
  36. shadows and inactive window dimming to bring back some of the Picom X11
  37. compositor functionality, which was commonly used with the i3 window manager.
  38. '';
  39. };
  40. })