default.nix 875 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. {
  2. config,
  3. nixpkgs,
  4. home,
  5. overlays,
  6. inputs,
  7. }: let
  8. system = "x86_64-linux";
  9. in
  10. home.lib.homeManagerConfiguration {
  11. modules = [
  12. {
  13. nixpkgs = {inherit config overlays;};
  14. home = rec {
  15. username = "ludovico";
  16. homeDirectory = "/home/${username}";
  17. /*
  18. NOTE: Do not change this
  19. unless you know what you're doing
  20. */
  21. stateVersion = "21.11";
  22. };
  23. }
  24. # Import modules from inputs
  25. inputs.hyprland.homeManagerModules.default
  26. inputs.nix-colors.homeManagerModules.default
  27. inputs.nur.hmModules.nur
  28. inputs.spicetify.homeManagerModule
  29. ./home.nix
  30. ];
  31. # Default nixpkgs for home.nix
  32. pkgs = nixpkgs.outputs.legacyPackages.${system};
  33. # Extra arguments passed to home.nix
  34. extraSpecialArgs = {inherit inputs system;};
  35. }