tmux.nix 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. ''
  2. # More friendly split pane
  3. bind-key h split-window -h
  4. bind-key v split-window -v
  5. set -g base-index 1
  6. set -g pane-base-index 1
  7. set-window-option -g pane-base-index 1
  8. set-option -g renumber-windows on
  9. unbind C-b
  10. bind -r "<" swap-window -d -t -1
  11. bind -r ">" swap-window -d -t +1
  12. bind c new-window -c
  13. bind Space last-window
  14. bind -r C-j resize-pane -D 5
  15. bind -r C-k resize-pane -U 5
  16. bind -r C-h resize-pane -L 5
  17. bind -r C-l resize-pane -R 5
  18. bind -n M-Left select-pane -L
  19. bind -n M-Right select-pane -R
  20. bind -n M-Up select-pane -U
  21. bind -n M-Down select-pane -D
  22. # quiet
  23. set -g visual-activity off
  24. set -g visual-bell off
  25. set -g visual-silence off
  26. setw -g monitor-activity off
  27. set -g bell-action none
  28. # Some tweaks to the status line
  29. set -g status-right "%H:%M"
  30. set -g window-status-current-style "underscore"
  31. # If running inside tmux ($TMUX is set), then change the status line to red
  32. %if #{TMUX}
  33. set -g status-bg red
  34. %endif
  35. # Enable RGB colour if running in xterm(1)
  36. set-option -sa terminal-overrides ",xterm*:Tc"
  37. # Change the default $TERM to tmux-256color
  38. set -g default-terminal "tmux-256color"
  39. ''