userChrome.nix 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. ''
  2. * {
  3. box-shadow: none !important;
  4. border: 0px solid !important;
  5. }
  6. #tabbrowser-tabs {
  7. --user-tab-rounding: 8px;
  8. }
  9. .tab-background {
  10. border-radius: var(--user-tab-rounding) var(--user-tab-rounding) 0px 0px !important; /* Connected */
  11. margin-block: 1px 0 !important; /* Connected */
  12. }
  13. #scrollbutton-up,
  14. #scrollbutton-down {
  15. /* 6/10/2021 */
  16. border-top-width: 1px !important;
  17. border-bottom-width: 0 !important;
  18. }
  19. .tab-background:is([selected], [multiselected]):-moz-lwtheme {
  20. --lwt-tabs-border-color: rgba(0, 0, 0, 0.5) !important;
  21. border-bottom-color: transparent !important;
  22. }
  23. [brighttext="true"]
  24. .tab-background:is([selected], [multiselected]):-moz-lwtheme {
  25. --lwt-tabs-border-color: rgba(255, 255, 255, 0.5) !important;
  26. border-bottom-color: transparent !important;
  27. } /* Container color bar visibility */
  28. .tabbrowser-tab[usercontextid]
  29. > .tab-stack
  30. > .tab-background
  31. > .tab-context-line {
  32. margin: 0px max(calc(var(--user-tab-rounding) - 3px), 0px) !important;
  33. }
  34. #TabsToolbar,
  35. #tabbrowser-tabs {
  36. --tab-min-height: 29px !important;
  37. }
  38. #main-window[sizemode="true"] #toolbar-menubar[autohide="true"] + #TabsToolbar,
  39. #main-window[sizemode="true"]
  40. #toolbar-menubar[autohide="true"]
  41. + #TabsToolbar
  42. #tabbrowser-tabs {
  43. --tab-min-height: 30px !important;
  44. }
  45. #scrollbutton-up,
  46. #scrollbutton-down {
  47. border-top-width: 0 !important;
  48. border-bottom-width: 0 !important;
  49. }
  50. #TabsToolbar,
  51. #TabsToolbar > hbox,
  52. #TabsToolbar-customization-target,
  53. #tabbrowser-arrowscrollbox {
  54. max-height: calc(var(--tab-min-height) + 1px) !important;
  55. }
  56. #TabsToolbar-customization-target toolbarbutton > .toolbarbutton-icon,
  57. #TabsToolbar-customization-target .toolbarbutton-text,
  58. #TabsToolbar-customization-target .toolbarbutton-badge-stack,
  59. #scrollbutton-up,
  60. #scrollbutton-down {
  61. padding-top: 7px !important;
  62. padding-bottom: 6px !important;
  63. }
  64. ''