search.nix 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. {pkgs}: {
  2. default = "Brave";
  3. force = true;
  4. engines = {
  5. "Brave" = {
  6. urls = [{template = "https://search.brave.com/search?q={searchTerms}";}];
  7. definedAliases = ["@b"];
  8. };
  9. "Nix Packages" = {
  10. urls = [
  11. {
  12. template = "https://search.nixos.org/packages";
  13. params = [
  14. {
  15. name = "channel";
  16. value = "unstable";
  17. }
  18. {
  19. name = "type";
  20. value = "packages";
  21. }
  22. {
  23. name = "query";
  24. value = "{searchTerms}";
  25. }
  26. ];
  27. }
  28. ];
  29. icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
  30. definedAliases = ["@np"];
  31. };
  32. "Home-Manager" = {
  33. urls = [
  34. {
  35. template = "https://rycee.gitlab.io/home-manager/options.html";
  36. }
  37. ];
  38. definedAliases = ["@hm"];
  39. };
  40. "NixOS Options" = {
  41. urls = [
  42. {
  43. template = "https://search.nixos.org/options";
  44. params = [
  45. {
  46. name = "channel";
  47. value = "unstable";
  48. }
  49. {
  50. name = "type";
  51. value = "packages";
  52. }
  53. {
  54. name = "query";
  55. value = "{searchTerms}";
  56. }
  57. ];
  58. }
  59. ];
  60. icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
  61. definedAliases = ["@no"];
  62. };
  63. "NixOS Wiki" = {
  64. urls = [
  65. {
  66. template = "https://nixos.wiki/index.php?search={searchTerms}";
  67. }
  68. ];
  69. icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
  70. definedAliases = ["@nw"];
  71. };
  72. };
  73. }