shell.nix 462 B

1234567891011121314151617
  1. # Shell for bootstrapping flake-enabled nix and home-manager
  2. # You can enter it through 'nix develop' or (legacy) 'nix-shell'
  3. {pkgs ? (import ./nixpkgs.nix) {}}: {
  4. default = pkgs.mkShell {
  5. # Enable experimental features without having to specify the argument
  6. NIX_CONFIG = "experimental-features = nix-command flakes";
  7. nativeBuildInputs = with pkgs; [
  8. home-manager
  9. git
  10. deadnix
  11. sops
  12. statix
  13. alejandra
  14. ];
  15. };
  16. }