default.nix 936 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. {
  2. lib,
  3. stdenvNoCC,
  4. fetchFromGitHub,
  5. util-linux,
  6. }:
  7. stdenvNoCC.mkDerivation {
  8. pname = "material-symbols";
  9. version = "unstable-3-22-23";
  10. src = fetchFromGitHub {
  11. owner = "google";
  12. repo = "material-design-icons";
  13. rev = "3912baecc97388955ce39f5e26bfb786a70cbe48";
  14. sha256 = "sha256-KZ2sgFKKUAaQeOIR5WIwotFS8WTsKkfczBcFz1xzH6A=";
  15. sparseCheckout = ["variablefont"];
  16. };
  17. nativeBuildInputs = [util-linux];
  18. installPhase = ''
  19. runHook preInstall
  20. rename '[FILL,GRAD,opsz,wght]' "" variablefont/*
  21. install -Dm755 variablefont/*.ttf -t $out/share/fonts/TTF
  22. install -Dm755 variablefont/*.woff2 -t $out/share/fonts/woff2
  23. runHook postInstall
  24. '';
  25. meta = with lib; {
  26. description = "Material Symbols icons by Google";
  27. homepage = "https://fonts.google.com/icons";
  28. license = lib.licenses.asl20;
  29. maintainers = with maintainers; [fufexan];
  30. platforms = platforms.all;
  31. };
  32. }