default.nix 572 B

12345678910111213141516171819202122232425
  1. {
  2. lib,
  3. fetchFromGitHub,
  4. ...
  5. }:
  6. fetchFromGitHub {
  7. pname = "Google-Sans-Fonts";
  8. owner = "sahibjotsaggu";
  9. repo = "Google-Sans-Fonts";
  10. rev = "b1826355d8212378e5fd6094bbe504268fa6f85d";
  11. fetchSubmodules = false;
  12. sha256 = "sha256-V2cZIXDEUNw/U+HtIlfyp9Nq3TixLjPFWtLoLMWDd/Q=";
  13. postFetch = ''
  14. mkdir -p $out/share/fonts/Google-Sans
  15. cp -r $out/*.ttf $out/share/fonts/Google-Sans
  16. '';
  17. meta = with lib; {
  18. description = "Google Sans Fonts";
  19. homepage = "https://github.com/sahibjotsaggu/Google-Sans-Fonts";
  20. platforms = platforms.all;
  21. };
  22. }