default.nix 727 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. {
  2. config,
  3. nixpkgs,
  4. inputs,
  5. overlays,
  6. ...
  7. }:
  8. nixpkgs.lib.nixosSystem rec {
  9. system = "x86_64-linux";
  10. modules = [
  11. {
  12. nix = import ../../nix-settings.nix {
  13. inherit inputs system nixpkgs;
  14. max-jobs = 4;
  15. };
  16. nixpkgs = {inherit config overlays;};
  17. networking.hostName = "sforza";
  18. /*
  19. NOTE: Do not change this
  20. unless you know what you're doing
  21. */
  22. system.stateVersion = "22.11";
  23. }
  24. # Import modules from inputs
  25. inputs.aagl.nixosModules.default
  26. inputs.impermanence.nixosModules.impermanence
  27. inputs.nur.nixosModules.nur
  28. inputs.sops-nix.nixosModules.sops
  29. ./configuration.nix
  30. ];
  31. specialArgs = {inherit inputs system;};
  32. }