default.nix 685 B

12345678910111213141516171819202122232425262728293031
  1. {
  2. lib,
  3. stdenvNoCC,
  4. sources,
  5. }:
  6. stdenvNoCC.mkDerivation {
  7. inherit (sources.san-francisco-pro) pname version src;
  8. buildPhase = ''
  9. runHook preBuild
  10. # Create the destination directory
  11. mkdir -p $out/share/fonts/San-Francisco-Pro
  12. # Copy the .ttf & .otf files to the destination directory
  13. cp -r $src/*.ttf $src/*.otf $out/share/fonts/San-Francisco-Pro
  14. runHook postBuild
  15. '';
  16. meta = {
  17. description = "San Francisco Pro Fonts";
  18. homepage = "https://github.com/sahibjotsaggu/San-Francisco-Pro-Fonts";
  19. license = lib.licenses.unfree;
  20. maintainers = with lib.maintainers; [
  21. ludovicopiero
  22. ];
  23. platforms = lib.platforms.all;
  24. };
  25. }