default.nix 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. { inputs, ... }:
  2. {
  3. systems = [ "x86_64-linux" ];
  4. perSystem =
  5. { pkgs, system, ... }:
  6. let
  7. sources = pkgs.callPackage ./_sources/generated.nix { };
  8. in
  9. {
  10. # This sets `pkgs` to a nixpkgs with allowUnfree option set.
  11. _module.args.pkgs = import inputs.nixpkgs {
  12. inherit system;
  13. overlays = [ ];
  14. config.allowUnfree = true;
  15. };
  16. packages = {
  17. catppuccin-fcitx5 = pkgs.callPackage ./catppuccin-fcitx5 { inherit sources; };
  18. iosevka-q = pkgs.callPackage ./iosevka-q { };
  19. firefox-gnome-theme = pkgs.callPackage ./firefox-gnome-theme { inherit sources; };
  20. pollymc = pkgs.callPackage ./pollymc { };
  21. tidal-hifi = pkgs.callPackage ./tidal-hifi { };
  22. san-francisco-pro = pkgs.callPackage ./san-francisco-pro { inherit sources; };
  23. sarasa-gothic = pkgs.callPackage ./sarasa-gothic { };
  24. spotify = pkgs.callPackage ./spotify { };
  25. whitesur-gtk-theme = pkgs.callPackage ./whitesur-gtk-theme { inherit sources; };
  26. };
  27. };
  28. }