hardware-configuration.nix 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. # Do not modify this file! It was generated by ‘nixos-generate-config’
  2. # and may be overwritten by future invocations. Please make changes
  3. # to /etc/nixos/configuration.nix instead.
  4. {
  5. config,
  6. lib,
  7. modulesPath,
  8. ...
  9. }:
  10. {
  11. imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
  12. fileSystems = {
  13. "/" = {
  14. device = "/dev/disk/by-label/ROOT";
  15. fsType = "btrfs";
  16. options = [
  17. "noatime"
  18. "compress=zstd"
  19. ];
  20. };
  21. "/home" = {
  22. device = "/dev/disk/by-label/HOME";
  23. fsType = "btrfs";
  24. neededForBoot = true; # for sops-nix
  25. options = [
  26. "noatime"
  27. "compress=zstd"
  28. ];
  29. };
  30. "/boot" = {
  31. device = "/dev/disk/by-label/BOOT";
  32. fsType = "vfat";
  33. options = [
  34. "fmask=0022"
  35. "dmask=0022"
  36. ];
  37. };
  38. "/home/airi/WinE" = {
  39. device = "/dev/disk/by-label/WinE";
  40. fsType = "ntfs";
  41. options = [
  42. "uid=1001"
  43. "gid=100"
  44. "rw"
  45. "user"
  46. "exec"
  47. "dmask=0002"
  48. "fmask=0113"
  49. "nofail"
  50. ];
  51. };
  52. "/home/airi/Media" = {
  53. device = "/dev/disk/by-label/Media";
  54. fsType = "btrfs";
  55. options = [
  56. "noatime"
  57. "compress=zstd"
  58. ];
  59. };
  60. };
  61. swapDevices = [ { device = "/dev/disk/by-uuid/5a271e1b-7bb8-4dd0-a3b5-de1dcd41560e"; } ];
  62. # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
  63. # (the default) this is the recommended approach. When using systemd-networkd it's
  64. # still possible to use this option, but it's recommended to use it in conjunction
  65. # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
  66. networking.useDHCP = lib.mkDefault true;
  67. # networking.interfaces.enp3s0.useDHCP = lib.mkDefault true;
  68. # networking.interfaces.wlp4s0.useDHCP = lib.mkDefault true;
  69. # slows down boot time
  70. systemd.services.NetworkManager-wait-online.enable = false;
  71. nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
  72. hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
  73. }