default.nix 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. {
  2. systems = [ "x86_64-linux" ];
  3. perSystem =
  4. { pkgs, ... }:
  5. let
  6. sources = pkgs.callPackage ./_sources/generated.nix { };
  7. in
  8. {
  9. packages = {
  10. iosevka-q = pkgs.callPackage ./iosevka-q { };
  11. firefox-gnome-theme = pkgs.callPackage ./firefox-gnome-theme { inherit sources; };
  12. san-francisco-pro = pkgs.callPackage ./san-francisco-pro { inherit sources; };
  13. sarasa-gothic = pkgs.callPackage ./sarasa-gothic { };
  14. swayfx = pkgs.callPackage ./swayfx { inherit sources; };
  15. spotify = pkgs.callPackage ./spotify { };
  16. waybar = pkgs.callPackage ./waybar { inherit sources; };
  17. wezterm = pkgs.darwin.apple_sdk_11_0.callPackage ./wezterm {
  18. inherit (pkgs.darwin.apple_sdk_11_0.frameworks)
  19. Cocoa
  20. CoreGraphics
  21. Foundation
  22. UserNotifications
  23. System
  24. ;
  25. inherit sources;
  26. };
  27. whitesur-gtk-theme = pkgs.callPackage ./whitesur-gtk-theme {
  28. inherit (pkgs.gnome) gnome-shell;
  29. inherit sources;
  30. };
  31. };
  32. };
  33. }