foot.nix 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. {colorscheme}:
  2. with colorscheme.colors; {
  3. main = {
  4. term = "xterm-256color";
  5. font = "Iosevka Nerd Font:size=13";
  6. dpi-aware = "auto";
  7. initial-window-size-chars = "82x23";
  8. initial-window-mode = "windowed";
  9. pad = "10x10";
  10. resize-delay-ms = 100;
  11. };
  12. colors = {
  13. alpha = "0.8";
  14. foreground = "${base05}"; # Text
  15. background = "${base00}"; # Base
  16. regular0 = "${base03}"; # Surface 1
  17. regular1 = "${base08}"; # red
  18. regular2 = "${base0B}"; # green
  19. regular3 = "${base0A}"; # yellow
  20. regular4 = "${base0D}"; # blue
  21. regular5 = "${base0F}"; # pink
  22. regular6 = "${base0C}"; # teal
  23. regular7 = "${base06}"; # Subtext 0
  24. # Subtext 1 ???
  25. bright0 = "${base04}"; # Surface 2
  26. bright1 = "${base08}"; # red
  27. bright2 = "${base0B}"; # green
  28. bright3 = "${base0A}"; # yellow
  29. bright4 = "${base0D}"; # blue
  30. bright5 = "${base0F}"; # pink
  31. bright6 = "${base0C}"; # teal
  32. bright7 = "${base07}"; # Subtext 0
  33. };
  34. mouse = {
  35. hide-when-typing = "yes";
  36. alternate-scroll-mode = "yes";
  37. };
  38. }