default.nix 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. {
  2. inputs,
  3. self,
  4. ...
  5. }:
  6. {
  7. flake.nixosConfigurations =
  8. let
  9. inherit (inputs.nixpkgs.lib) nixosSystem;
  10. sharedModules = import ../modules;
  11. pkgs-stable = import inputs.nixpkgs-stable {
  12. system = "x86_64-linux";
  13. };
  14. specialArgs = {
  15. inherit inputs pkgs-stable self;
  16. };
  17. in
  18. {
  19. sforza = nixosSystem {
  20. inherit specialArgs;
  21. modules = [
  22. sharedModules
  23. inputs.chaotic.nixosModules.default
  24. inputs.home-manager.nixosModules.home-manager
  25. ./sforza/configuration.nix
  26. {
  27. myOptions = {
  28. dnscrypt2.enable = true;
  29. teavpn2.enable = false;
  30. spotify.enable = true;
  31. fish.enable = true;
  32. floorp.enable = false;
  33. vars = {
  34. colorScheme = "everforest-dark-hard";
  35. withGui = true; # Enable hyprland & all gui stuff
  36. email = "lewdovico@gnuweeb.org";
  37. };
  38. };
  39. }
  40. ];
  41. };
  42. };
  43. }