12345678910111213141516171819202122232425262728293031 |
- pkgname=nginx-hardened-preferences
- pkgver=0.1
- pkgrel=1
- pkgdesc="Creates clean chroot for Nginx to run in, and cleans left over files when done running."
- arch=(any)
- license=(GPL-2)
- depends=('nginx')
- install=nginx-hardened-preferences.install
- source=('nginx-hardened.initd'
- 'nginx-hardened.run'
- 'nginx-hardened.sh'
- 'nginxchroot.sh'
- 'nginx.conf'
- 'example.conf')
-
- sha512sums=('9b4a8b302c3117458166db283db2e69d001c9e4aa44d34035f1d8c3416579296929dfb0bb58164dd33923658176de74a0060f216cb71cf07fd727e0b52a39899'
- '934c67c65a5815631a6a8b58e93961dc0da06f7618c7575223739a399fb01f58d74204d13e04ceaeb1260092b9fc21555901191fc71392d4cd3dfc8693d8cf1a'
- '2b20dbcd756d162bcc76a7a2b342ed33be6db60bf6520a667fe054f51d1f1df0423b89d9b7536be24b7813207dcfbe3c9ebb13017cce8f5fa5c36278aab6dd3c'
- '8a489e1b42e7061bb91b19a47a2b82157c6200ee5c89c9c54fc72788240c990a15404d122b102d34344b15a21542d0a72b7d3c8a844a00986cb902b4003819e9'
- 'c77eff62c0689c31245d34a37433fdaae07e8d4564481a71b93df706504a497528535e77f98da02fe1ae326caa302c079ae95e09ec3689be2ea085a8a231ff8d'
- '70d38463ab8ab8646b4c666df531d1b1738418a70ef5f6f955666a62109ee9af760096b90f7479a36df8307b94e671501d9d08d201dc23e637a12db0a318fd1d')
- package() {
- mkdir -p ${pkgdir}/usr/libexec/nginx-hardened-scripts
- install -Dm755 nginx-hardened.sh ${pkgdir}/usr/libexec/nginx-hardened-scripts/nginx-hardened.sh
- install -Dm755 nginxchroot.sh ${pkgdir}/usr/libexec/nginx-hardened-scripts/nginxchroot.sh
- install -Dm755 nginx.conf ${pkgdir}/usr/libexec/nginx-hardened-scripts/nginx.conf
- install -Dm755 example.conf ${pkgdir}/usr/libexec/nginx-hardened-scripts/example.conf
- install -Dm755 nginx-hardened.initd ${pkgdir}/etc/init.d/nginx-hardened
- install -Dm755 nginx-hardened.run "$pkgdir"/etc/sv/nginx-hardened/run
- }
|