tpm.SlackBuild 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. #!/bin/sh
  2. # Slackware build script for tpm
  3. # Copyright 2015-2016, 2020 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=tpm
  23. VERSION=${VERSION:-1.3.3}
  24. BUILD=${BUILD:-2}
  25. TAG=${TAG:-_SBo}
  26. ARCH=noarch
  27. CWD=$(pwd)
  28. TMP=${TMP:-/tmp/SBo}
  29. PKG=$TMP/package-$PRGNAM
  30. OUTPUT=${OUTPUT:-/tmp}
  31. set -eu
  32. rm -rf $PKG
  33. mkdir -p $TMP $PKG $OUTPUT
  34. cd $TMP
  35. rm -rf $PRGNAM-$VERSION
  36. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  37. cd $PRGNAM-$VERSION
  38. chown -R root:root .
  39. find -L . \
  40. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  41. -o -perm 511 \) -exec chmod 755 {} \; -o \
  42. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  43. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  44. make install \
  45. PREFIX=/usr \
  46. MANDIR=/usr/man \
  47. DESTDIR=$PKG
  48. find $PKG/usr/man -type f -exec gzip -9 {} \;
  49. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  50. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  51. cp -a LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
  52. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  53. mkdir -p $PKG/install
  54. cat $CWD/slack-desc > $PKG/install/slack-desc
  55. cd $PKG
  56. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}