ksh-openbsd.SlackBuild 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108
  1. #!/bin/sh
  2. # Copyright (c) 2010-2018 LEVAI Daniel
  3. # Copyright (c) 2019 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use in source and binary forms, with or without
  7. # modification, are permitted provided that the following conditions are met:
  8. # * Redistributions of source code must retain the above copyright
  9. # notice, this list of conditions and the following disclaimer.
  10. # * Redistributions in binary form must reproduce the above copyright
  11. # notice, this list of conditions and the following disclaimer in the
  12. # documentation and/or other materials provided with the distribution.
  13. # * Neither the name of the <organization> nor the
  14. # names of its contributors may be used to endorse or promote products
  15. # derived from this software without specific prior written permission.
  16. #
  17. # THIS SOFTWARE IS PROVIDED ''AS IS'' AND ANY
  18. # EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
  19. # WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
  20. # DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER BE LIABLE FOR ANY
  21. # DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
  22. # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
  23. # LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
  24. # ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  25. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
  26. # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  27. PRGNAM=ksh-openbsd
  28. VERSION=${VERSION:-20190804}
  29. BUILD=${BUILD:-1}
  30. TAG=${TAG:-_SBo}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. CWD=$(pwd)
  39. TMP=${TMP:-/tmp/SBo}
  40. PKG=$TMP/package-$PRGNAM
  41. OUTPUT=${OUTPUT:-/tmp}
  42. if [ "${ARCH}" == "i586" ];then
  43. SLKCFLAGS='-march=i586 -mtune=i686'
  44. LIBDIRSUFFIX=""
  45. elif [ "$ARCH" == "i686" ]; then
  46. SLKCFLAGS="-march=i686 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "${ARCH}" == "x86_64" ];then
  49. SLKCFLAGS='-fPIC'
  50. LIBDIRSUFFIX="64"
  51. else
  52. SLKCFLAGS="-O2"
  53. LIBDIRSUFFIX=""
  54. fi
  55. set -eu
  56. rm -rf $PKG
  57. mkdir -p $TMP $PKG $OUTPUT
  58. cd $TMP
  59. rm -rf $PRGNAM-$VERSION
  60. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  61. cd $PRGNAM-$VERSION
  62. chown -R root:root .
  63. find -L . \
  64. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  65. -o -perm 511 \) -exec chmod 755 {} \; -o \
  66. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  67. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  68. # Makefile: Support a custom binary name.
  69. # https://github.com/levaidaniel/ksh-openbsd/pull/1
  70. patch -p1 < $CWD/oksh.patch
  71. # clang 9 build error.
  72. # https://github.com/levaidaniel/ksh-openbsd/issues/2
  73. sed -i '/DEF_WEAK/d' vis.c
  74. CFLAGS="$SLKCFLAGS" make
  75. make check BINNAM=oksh
  76. make install BINNAM=oksh DESTDIR=$PKG
  77. mkdir -p $PKG/usr/bin
  78. ln -s /bin/oksh $PKG/usr/bin/oksh
  79. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  80. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  81. find $PKG/usr/man -type f -exec gzip -9 {} \;
  82. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  83. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  84. cp -a Changelog.ksh-openbsd LEGAL README $PKG/usr/doc/$PRGNAM-$VERSION
  85. cp $CWD/README $PKG/usr/doc/$PRGNAM-$VERSION/README.$PRGNAM
  86. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  87. mkdir -p $PKG/install
  88. cat $CWD/slack-desc > $PKG/install/slack-desc
  89. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  90. cd $PKG
  91. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}