solarus.SlackBuild 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. #!/bin/sh
  2. # Slackware build script for solarus
  3. # Copyright 2015-2020 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=solarus
  23. VERSION=${VERSION:-1.6.4}
  24. BUILD=${BUILD:-2}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -eu
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf $PRGNAM-v$VERSION
  55. tar xvf $CWD/$PRGNAM-v$VERSION.tar.gz
  56. cd $PRGNAM-v$VERSION
  57. chown -R root:root .
  58. find -L . \
  59. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  60. -o -perm 511 \) -exec chmod 755 {} \; -o \
  61. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  62. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  63. if pkg-config --exists Qt5Core; then
  64. GUI=ON
  65. else
  66. GUI=OFF
  67. fi
  68. # cmake: Fix compatiblity with cmake-3.5.2.
  69. # https://gitlab.com/solarus-games/solarus/-/merge_requests/1353
  70. patch -p1 < $CWD/cmake.patch
  71. # Workaround SDL_WINDOW_FULLSCREEN_DESKTOP issues.
  72. # https://gitlab.com/solarus-games/solarus/-/merge_requests/1355
  73. patch -p1 -i $CWD/fullscreen.patch
  74. mkdir -p build
  75. cd build
  76. cmake \
  77. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  78. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  79. -DCMAKE_INSTALL_PREFIX=/usr \
  80. -DSOLARUS_EXECUTABLE_INSTALL_DESTINATION:PATH=games \
  81. -DSOLARUS_MANUAL_INSTALL_DESTINATION:PATH=man \
  82. -DSOLARUS_LIBRARY_INSTALL_DESTINATION:PATH=lib${LIBDIRSUFFIX} \
  83. -DSOLARUS_DEFAULT_QUEST=/usr/share/games/$PRGNAM/zsdx \
  84. -DSOLARUS_GUI=$GUI \
  85. -DCMAKE_SKIP_RPATH=TRUE \
  86. -DCMAKE_BUILD_TYPE=Release ..
  87. make
  88. make install DESTDIR=$PKG
  89. cd ..
  90. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  91. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  92. find $PKG/usr/man -type f -exec gzip -9 {} \;
  93. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  94. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  95. cp -a changelog.txt readme.md license.txt license_gpl.txt \
  96. $PKG/usr/doc/$PRGNAM-$VERSION
  97. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  98. mkdir -p $PKG/install
  99. cat $CWD/slack-desc > $PKG/install/slack-desc
  100. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  101. cd $PKG
  102. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}