antares.SlackBuild 3.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. #!/bin/sh
  2. # Slackware build script for antares
  3. # Copyright 2018, 2020 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=antares
  23. VERSION=${VERSION:-0.9.1}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. set -eu
  38. rm -rf $PKG
  39. mkdir -p $TMP $PKG $OUTPUT
  40. cd $TMP
  41. rm -rf $PRGNAM-$VERSION
  42. unzip $CWD/$PRGNAM-$VERSION.zip
  43. cd $PRGNAM-$VERSION
  44. chown -R root:root .
  45. find -L . \
  46. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  47. -o -perm 511 \) -exec chmod 755 {} \; -o \
  48. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  49. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  50. # Prevent downloading the source during install
  51. mkdir -p $PKG/usr/share/games/$PRGNAM/downloads
  52. cp $CWD/Ares-1.2.0.zip $PKG/usr/share/games/$PRGNAM/downloads
  53. # Don't connect to the accessibility bus.
  54. # https://github.com/arescentral/antares/issues/276
  55. export NO_AT_BRIDGE=1
  56. # Use a system version of gn.
  57. sed -i 's|build/lib/bin/gn|gn|' build/lib/scripts/cfg.py
  58. # Revert: Update to python3 (scripts/antares_launcher.py)
  59. # Doesn't work with python3 and removed upstream.
  60. # https://github.com/arescentral/antares/commit/0137f46c58e26352b2ba88cb581974f3f263ba3f
  61. patch -R -p1 < $CWD/python.patch
  62. # configure is a python script
  63. ./configure \
  64. --prefix=/usr
  65. make NINJA="${NINJA:-ninja} -C out/cur" install DESTDIR=$PKG
  66. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  67. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  68. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  69. cp -a AUTHORS CONTRIBUTING COPYING COPYING.LESSER README.rst \
  70. $PKG/usr/doc/$PRGNAM-$VERSION
  71. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  72. mkdir -p $PKG/install
  73. cat $CWD/slack-desc > $PKG/install/slack-desc
  74. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  75. cd $PKG
  76. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}