wine-nine-standalone.SlackBuild 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165
  1. #!/bin/sh
  2. # Slackware build script for wine-nine-standalone
  3. # Copyright 2019 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=wine-nine-standalone
  23. VERSION=${VERSION:-0.4}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -eu
  51. exists () {
  52. v=1
  53. while [ $# -gt 0 ]; do
  54. arg="$1"; shift
  55. case "$arg" in ''|*/) continue ;; esac
  56. x="${arg##*/}" z="${arg%/*}"
  57. [ ! -f "$z/$x" ] || [ ! -x "$z/$x" ] && [ "$z/$x" = "$arg" ] && continue
  58. [ "$x" = "$z" ] && [ -x "$z/$x" ] && [ ! -f "$arg" ] && z=
  59. p=":$z:$PATH"
  60. while [ "$p" != "${p#*:}" ]; do
  61. p="${p#*:}"; d="${p%%:*}"
  62. if [ -f "$d/$x" ] && [ -x "$d/$x" ]; then
  63. printf %s\\n "$d/$x"
  64. v=0
  65. break
  66. fi
  67. done
  68. done
  69. return $v
  70. }
  71. rm -rf $PKG
  72. mkdir -p $TMP $PKG $OUTPUT
  73. cd $TMP
  74. rm -rf $PRGNAM-$VERSION
  75. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  76. cd $PRGNAM-$VERSION
  77. chown -R root:root .
  78. find -L . \
  79. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  80. -o -perm 511 \) -exec chmod 755 {} \; -o \
  81. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  82. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  83. if [ "${DEBUG:=0}" != 0 ]; then
  84. RELEASE=debug
  85. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
  86. else
  87. RELEASE=plain
  88. fi
  89. if [ "$ARCH" = x86_64 ]; then
  90. if exists wine >/dev/null 2>&1 && exists wine64 >/dev/null 2>&1; then
  91. arch='32 64'
  92. elif exists wine >/dev/null 2>&1; then
  93. arch=32
  94. else
  95. arch=64
  96. fi
  97. else
  98. arch=32
  99. fi
  100. ./bootstrap.sh
  101. eval "set -- $arch"
  102. for bin do
  103. case "$bin" in
  104. 32 ) suffix= ;;
  105. 64 ) suffix=64 ;;
  106. esac
  107. CFLAGS="$SLKCFLAGS" \
  108. CXXFLAGS="$SLKCFLAGS" \
  109. meson \
  110. --prefix=/tmp \
  111. --libdir=lib$bin \
  112. --bindir=bin$bin \
  113. --cross-file=tools/cross-wine$bin \
  114. -Dstrip=false \
  115. -Dbuildtype=$RELEASE \
  116. build$bin
  117. "${NINJA:=ninja}" -C build$bin
  118. DESTDIR=. "$NINJA" -C build$bin install
  119. mkdir -p $PKG/usr/lib$suffix/wine/fakedlls
  120. cp ./build$bin/tmp/bin$bin/ninewinecfg.exe.so \
  121. $PKG/usr/lib$suffix/wine/fakedlls/ninewinecfg.exe
  122. cp ./build$bin/tmp/lib$bin/d3d9-nine.dll.so \
  123. $PKG/usr/lib$suffix/wine/fakedlls/d3d9-nine.dll
  124. chmod 0644 $PKG/usr/lib$suffix/wine/fakedlls/ninewinecfg.exe
  125. chmod 0644 $PKG/usr/lib$suffix/wine/fakedlls/d3d9-nine.dll
  126. mkdir -p $PKG/usr/bin
  127. cat > $PKG/usr/bin/ninewinecfg$suffix <<EOF
  128. #!/bin/sh
  129. wine$suffix /usr/lib$suffix/wine/fakedlls/ninewinecfg.exe
  130. EOF
  131. chmod 0755 $PKG/usr/bin/ninewinecfg$suffix
  132. done
  133. if [ "$DEBUG" = 0 ]; then
  134. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  135. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  136. fi
  137. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  138. cp LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
  139. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  140. mkdir -p $PKG/install
  141. cat $CWD/slack-desc > $PKG/install/slack-desc
  142. cd $PKG
  143. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}