pcsx2.SlackBuild 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159
  1. #!/bin/sh
  2. # Slackware build script for pcsx2
  3. # Copyright 2016-2018, 2020 Hunter Sezen California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=pcsx2
  23. VERSION=${VERSION:-1.6.0}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=core2"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -eu
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf $PRGNAM-$VERSION
  55. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  56. cd $PRGNAM-$VERSION
  57. chown -R root:root .
  58. find -L . \
  59. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  60. -o -perm 511 \) -exec chmod 755 {} \; -o \
  61. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  62. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  63. # pcsx2 does not support x86_64 yet and does
  64. # not plan to for the foreseeable future.
  65. BINDIR=; MULTILIB=
  66. if [ "$ARCH" = 'x86_64' ]; then
  67. BINDIR='/32'
  68. MULTILIB='-DCMAKE_TOOLCHAIN_FILE=cmake/linux-compiler-i386-multilib.cmake'
  69. fi
  70. RELEASE=Debug
  71. if [ "${DEVEL:-0}" != 0 ]; then
  72. DEBUG=1
  73. RELEASE=Devel
  74. fi
  75. if [ "${DEBUG:=0}" != 0 ]; then
  76. [ "${ASAN:=FALSE}" != FALSE ] && ASAN=TRUE
  77. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
  78. else
  79. ASAN=FALSE
  80. RELEASE=Release
  81. fi
  82. [ "${EGL_API:=OFF}" != OFF ] && EGL_API=ON
  83. # Handle this in doinst.sh instead
  84. # https://github.com/PCSX2/pcsx2/issues/2699
  85. sed -i '/setcap/d' pcsx2/CMakeLists.txt
  86. # Use a font included with Slackware
  87. # osd error: 'Failed to init the freetype face'
  88. sed -i \
  89. 's|truetype/freefont/FreeSerif.ttf|TTF/LiberationSerif-Regular.ttf|' \
  90. plugins/GSdx/GSdx.cpp
  91. # spu2-x: Make portaudio an optional dependency.
  92. # https://github.com/PCSX2/pcsx2/pull/3110
  93. # https://github.com/PCSX2/pcsx2/commit/84d090e2fde50c66b965b84c73abd9f04a1770dd
  94. patch -p1 < $CWD/portaudio.patch
  95. mkdir -p build
  96. cd build
  97. cmake \
  98. -DCMAKE_C_FLAGS="$SLKCFLAGS" \
  99. -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
  100. -DCMAKE_INSTALL_PREFIX=/usr \
  101. -DDOC_DIR=/usr/doc/$PRGNAM-$VERSION \
  102. -DMAN_DIR=/usr/man \
  103. -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin${BINDIR}/wx-config \
  104. -DwxWidgets_wxrc_EXECUTABLE=/usr/bin${BINDIR}/wxrc-3.0 \
  105. -DBUILD_REPLAY_LOADERS=TRUE \
  106. -DDISABLE_BUILD_DATE=ON \
  107. -DGSDX_LEGACY=ON \
  108. -DPACKAGE_MODE=ON \
  109. -DXDG_STD=ON \
  110. -DEGL_API=$EGL_API \
  111. -DUSE_ASAN=$ASAN \
  112. $MULTILIB \
  113. -DCMAKE_SKIP_RPATH=TRUE \
  114. -DCMAKE_BUILD_TYPE=$RELEASE ..
  115. make
  116. make install DESTDIR=$PKG
  117. cd ..
  118. if [ "$DEBUG" = 0 ]; then
  119. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  120. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  121. fi
  122. find $PKG/usr/man -type f -exec gzip -9 {} \;
  123. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  124. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  125. cp -a pcsx2/Docs/* bin/docs/*.html bin/docs/*.txt CONTRIBUTING.md COPYING* \
  126. README.md $PKG/usr/doc/$PRGNAM-$VERSION
  127. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  128. mkdir -p $PKG/install
  129. cat $CWD/slack-desc > $PKG/install/slack-desc
  130. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  131. # Fix doinst.sh for x86_64
  132. [ "$ARCH" != 'x86_64' ] ||
  133. sed -i 's|-loaders |-loaders-32 |' $PKG/install/doinst.sh
  134. cd $PKG
  135. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}