cmake-template.SlackBuild 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. #!/bin/sh
  2. # Slackware build script for <appname>
  3. # Copyright <year> <you> <where you live>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # |-----------------------------------------------------------------| #
  23. # REMOVE THIS ENTIRE BLOCK OF TEXT #
  24. #
  25. # A license is required, and we strongly suggest you use the above
  26. # BSD/MIT style license. We DO NOT accept "Public Domain" scripts.
  27. # Public domain is not valid in some countries, and no license is
  28. # worse than a "bad" license in those countries.
  29. #
  30. # This template is not meant to be a 'cut and paste' script to
  31. # enable any random user to make a working package. While
  32. # we're certainly not discouraging use of this template, if
  33. # you haven't manually gone through each step of the process
  34. # without the build script (typically as a normal user, as this
  35. # will reveal problems that you won't see as root), then there's
  36. # a good chance that something important is missing from your
  37. # submission.
  38. # When using this template script, please remove as many of
  39. # these unnecessary comments as possible. Commented code is
  40. # a good thing, but if it's obvious, there's no need to comment it.
  41. #
  42. # AGAIN, REMOVE THE COMMENTS IF THEY ARE NOT NEEDED - DON'T JUST
  43. # DELETE THIS BLOCK OF TEXT WITHOUT BOTHERING TO READ WHAT'S IN IT.
  44. #
  45. # |-----------------------------------------------------------------| #
  46. PRGNAM=appname # replace with name of program
  47. VERSION=${VERSION:-1.4.1} # replace with version of program
  48. BUILD=${BUILD:-1}
  49. TAG=${TAG:-_SBo} # the "_SBo" is required
  50. # Automatically determine the architecture we're building on:
  51. if [ -z "$ARCH" ]; then
  52. case "$( uname -m )" in
  53. i?86) ARCH=i586 ;;
  54. arm*) ARCH=arm ;;
  55. # Unless $ARCH is already set, use uname -m for all other archs:
  56. *) ARCH=$( uname -m ) ;;
  57. esac
  58. fi
  59. CWD=$(pwd)
  60. TMP=${TMP:-/tmp/SBo} # For consistency's sake, use this
  61. PKG=$TMP/package-$PRGNAM
  62. OUTPUT=${OUTPUT:-/tmp} # Drop the package in /tmp
  63. if [ "$ARCH" = "i586" ]; then
  64. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  65. LIBDIRSUFFIX=""
  66. elif [ "$ARCH" = "i686" ]; then
  67. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  68. LIBDIRSUFFIX=""
  69. elif [ "$ARCH" = "x86_64" ]; then
  70. SLKCFLAGS="-O2 -fPIC"
  71. LIBDIRSUFFIX="64"
  72. else
  73. SLKCFLAGS="-O2"
  74. LIBDIRSUFFIX=""
  75. fi
  76. set -e # Exit on most errors
  77. rm -rf $PKG
  78. mkdir -p $TMP $PKG $OUTPUT
  79. cd $TMP
  80. rm -rf $PRGNAM-$VERSION
  81. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  82. cd $PRGNAM-$VERSION
  83. chown -R root:root .
  84. find -L . \
  85. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  86. -o -perm 511 \) -exec chmod 755 {} \; -o \
  87. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  88. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  89. # Your application will probably need different cmake flags; these are only
  90. # examples. You might use 'ccmake' to see the available flags...
  91. mkdir -p build
  92. cd build
  93. cmake \
  94. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  95. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  96. -DCMAKE_INSTALL_PREFIX=/usr \
  97. -DLIB_SUFFIX=${LIBDIRSUFFIX} \
  98. -DMAN_INSTALL_DIR=/usr/man \
  99. -DCMAKE_BUILD_TYPE=Release ..
  100. make
  101. make install DESTDIR=$PKG
  102. cd ..
  103. # Strip binaries and libraries - this can be done with 'make install-strip'
  104. # in many source trees, and that's usually acceptable, if not, use this:
  105. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  106. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  107. # Compress man pages
  108. # If the man pages are installed to /usr/share/man instead, you'll need to
  109. # move them manually.
  110. find $PKG/usr/man -type f -exec gzip -9 {} \;
  111. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  112. # Compress info pages and remove the package's dir file
  113. # If no info pages are installed by the software, don't leave this in the script
  114. rm -f $PKG/usr/info/dir
  115. gzip -9 $PKG/usr/info/*.info*
  116. # Remove perllocal.pod and other special files that don't need to be installed,
  117. # as they will overwrite what's already on the system. If this is not needed,
  118. # remove it from the script.
  119. find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
  120. # Copy program documentation into the package
  121. # The included documentation varies from one application to another, so be sure
  122. # to adjust your script as needed
  123. # Also, include the SlackBuild script in the documentation directory
  124. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  125. cp -a \
  126. <documentation> \
  127. $PKG/usr/doc/$PRGNAM-$VERSION
  128. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  129. # Copy the slack-desc (and a custom doinst.sh if necessary) into ./install
  130. mkdir -p $PKG/install
  131. cat $CWD/slack-desc > $PKG/install/slack-desc
  132. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  133. # Make the package; be sure to leave it in $OUTPUT
  134. # If package symlinks need to be created during install *before*
  135. # your custom contents of doinst.sh runs, then add the -p switch to
  136. # the makepkg command below -- see makepkg(8) for details
  137. cd $PKG
  138. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}