CHANGELOG 2.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. spiped-1.6.1
  2. * New option -u username:groupname (spiped): change the user and/or group
  3. ownership of the process.
  4. * Use RDRAND as an additional source of entropy on CPUs which support it.
  5. * Use SHANI instructions on CPUs which support them.
  6. * Warn about failed connections and exit with non-zero status (spipe).
  7. spiped-1.6.0
  8. * The -n option (spiped) is no longer limited to a maximum limit of
  9. 500 simultaneous connections.
  10. * The -k option now accepts "-" as a synonym for standard input.
  11. * New option -v (spipe/spiped): Print version number.
  12. * Add workaround for docker signal-handling bug in spiped.
  13. * Perform a graceful shutdown on SIGTERM.
  14. spiped-1.5.0
  15. * Attempt to set the TCP_NODELAY socket option on connections, in order
  16. to avoid punishing latencies from TCP nagling.
  17. spiped-1.4.2
  18. * Fix crash on platforms which support AESNI (i386, amd64) but do not
  19. automatically provide 16-byte alignment to large memory allocations
  20. (glibc, possibly others).
  21. spiped-1.4.1
  22. * Fix build on OS X, and improve strict POSIX compliance.
  23. * Improved zeroing of sensitive cryptographic data.
  24. spiped-1.4.0
  25. * Add automatic detection of compiler support (at compile-time) and CPU
  26. support (at run-time) for x86 "AES New Instructions"; and when available,
  27. use these to improve cryptographic performance.
  28. * Add support for -g option, which makes {spiped, spipe} require perfect
  29. forward secrecy by dropping connections if the peer endpoint is detected to
  30. be running using the -f option.
  31. spiped-1.3.1
  32. * Fix build by adding missing <stdint.h> #include.
  33. * Minor code cleanups.
  34. spiped-1.3.0
  35. * Bug fix: spiped now correctly closes connections which have been reset;
  36. in earlier versions spiped could erroneously hold "dead" connections open
  37. as long as they remained idle.
  38. * Man pages added.
  39. * Protocol-layer keep-alives are now enabled by default.
  40. * New option -j (spipe/spiped): Disable protocol-layer keep-alives.
  41. * In spiped the target address is now re-resolved every 60 seconds by default.
  42. * New option -R (spiped): Do not re-resolve target address.
  43. * New option -r <rtime> (spiped): Re-resolve target address every <rtime>
  44. seconds.
  45. spiped-1.2.2
  46. * Build fixes for some strictly POSIX-conforming platforms.
  47. * Detect and work around compilers which are POSIX-noncompliant in their
  48. handling of -rt and -lxnet options.
  49. * Minor documentation and typo fixes.
  50. spiped-1.2.1
  51. * Fix build by adding missing <stdint.h> #include.
  52. spiped-1.2.0
  53. * New utility "spipe": A client for the spiped protocol, handling a single
  54. connection with standard input/output as one end.
  55. * Code rearrangement with no functional consequences.
  56. * Minor bug and documentation fixes.
  57. spiped-1.1.0
  58. * New option -D: Wait until DNS lookups succeed.
  59. * New option -F: Don't daemonize.
  60. * Use SO_REUSEADDR to avoid 'socket address already in use' error (most
  61. importantly, if spiped is killed and restarted).
  62. * Minor bug and style fixes.
  63. spiped-1.0.0
  64. * Initial release