git.slackware.md 780 B

Preliminary steps:

git config user.email khronosschoty@posteo.org
git config user.name khronosschoty
git config --global gpg.program gpg2
git config --global user.signingkey <your private gpg key here>
git config commit.gpgsign true

Create a new repository on the command line

git add README.md
git commit -m "first commit"

Use ssh address instead of http based, and make sure to have an ssh key generated. This removes the need for giving git your password every time you want to make a commit.

git remote add origin git@notabug.org:khronosschoty/mars.SlackBuilds.git
git push -u origin master

Push an existing repository from the command line

git remote add origin git@notabug.org:khronosschoty/mars.SlackBuilds.git
git push -u origin master