pcsx2.SlackBuild 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163
  1. #!/bin/sh
  2. # Slackware build script for pcsx2
  3. # Copyright 2015-2019 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=pcsx2
  23. BRANCH=${BRANCH:-master}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_git}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=core2"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -eu
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf $PRGNAM
  55. git clone --depth=1 -b $BRANCH https://github.com/PCSX2/$PRGNAM
  56. cd $PRGNAM
  57. [ "${COMMIT:=}" ] && git fetch --unshallow --tags && git checkout "$COMMIT"
  58. HEAD="$(git rev-parse --short HEAD)"
  59. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  60. VERSION="${DATE}_$HEAD"
  61. chown -R root:root .
  62. find -L . \
  63. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  64. -o -perm 511 \) -exec chmod 755 {} \; -o \
  65. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  66. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  67. # pcsx2 does not support x86_64 yet and does
  68. # not plan to for the foreseeable future.
  69. BINDIR=; MULTILIB=
  70. if [ "$ARCH" = 'x86_64' ]; then
  71. BINDIR='/32'
  72. MULTILIB='-DCMAKE_TOOLCHAIN_FILE=cmake/linux-compiler-i386-multilib.cmake'
  73. fi
  74. RELEASE=Debug
  75. if [ "${DEVEL:-0}" != 0 ]; then
  76. DEBUG=1
  77. RELEASE=Devel
  78. fi
  79. if [ "${DEBUG:=0}" != 0 ]; then
  80. [ "${ASAN:=FALSE}" != FALSE ] && ASAN=TRUE
  81. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
  82. else
  83. ASAN=FALSE
  84. RELEASE=Release
  85. fi
  86. [ "${EGL_API:=OFF}" != OFF ] && EGL_API=ON
  87. [ "${OPENCL:=OFF}" != OFF ] && OPENCL=ON
  88. # Handle this in doinst.sh instead
  89. # https://github.com/PCSX2/pcsx2/issues/2699
  90. sed -i '/setcap/d' pcsx2/CMakeLists.txt
  91. # Use a font included with Slackware
  92. # osd error: 'Failed to init the freetype face'
  93. sed -i \
  94. 's|truetype/freefont/FreeSerif.ttf|TTF/LiberationSerif-Regular.ttf|' \
  95. plugins/GSdx/GSdx.cpp
  96. mkdir -p build
  97. cd build
  98. cmake -GNinja \
  99. -DCMAKE_C_FLAGS="$SLKCFLAGS" \
  100. -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
  101. -DCMAKE_INSTALL_PREFIX=/usr \
  102. -DDOC_DIR=/usr/doc/$PRGNAM-$VERSION \
  103. -DMAN_DIR=/usr/man \
  104. -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin${BINDIR}/wx-config \
  105. -DwxWidgets_wxrc_EXECUTABLE=/usr/bin${BINDIR}/wxrc-3.0 \
  106. -DBUILD_REPLAY_LOADERS=TRUE \
  107. -DDISABLE_BUILD_DATE=ON \
  108. -DGSDX_LEGACY=ON \
  109. -DPACKAGE_MODE=ON \
  110. -DXDG_STD=ON \
  111. -DEGL_API=$EGL_API \
  112. -DOPENCL_API=$OPENCL \
  113. -DUSE_ASAN=$ASAN \
  114. $MULTILIB \
  115. -DCMAKE_BUILD_TYPE=$RELEASE ..
  116. "${NINJA:=ninja}"
  117. DESTDIR=$PKG "$NINJA" install
  118. cd ..
  119. # Breaks the build with clang
  120. # https://github.com/PCSX2/pcsx2/issues/3096
  121. # -DDISABLE_ADVANCE_SIMD=ON \
  122. if [ "$DEBUG" = 0 ]; then
  123. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  124. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  125. fi
  126. find $PKG/usr/man -type f -exec gzip -9 {} \;
  127. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  128. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  129. cp -a pcsx2/Docs/* bin/docs/*.html bin/docs/*.txt CONTRIBUTING.md COPYING* \
  130. README.md $PKG/usr/doc/$PRGNAM-$VERSION
  131. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  132. mkdir -p $PKG/install
  133. cat $CWD/slack-desc > $PKG/install/slack-desc
  134. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  135. # Fix doinst.sh for x86_64
  136. [ "$ARCH" = 'x86_64' ] &&
  137. sed -i 's|-loaders |-loaders-32 |' $PKG/install/doinst.sh
  138. cd $PKG
  139. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}